7

On my Lubuntu 16.04 I connected to my NAS and was not able to delete files. The error message was something like:

Deletion log file could not be created: No authorization.

My connection to the share is established through:

sudo mount -t cifs -o user=USERSERVER,uid=LOCALUSER,gid=LOCALGROUP,username=USERSERVER,password=PW //192.168.0.102/RAID6 /media/OMV
  • 7
    Just FYI, you can run commands with modified environment, so whenever you need to output error in English, do LC_ALL=C command arg1 arg2 – Sergiy Kolodyazhnyy Jan 17 '17 at 9:21
  • 2
    Thanks for this comment, which related to the fact that I originally stated the error in german: "Löschprotokolldatei konnte nicht angelegt werden". I still find this usefull to be in here, because there is practically no evidence of this error findable via google in german at the moment. Thanks! – Ben Jan 17 '17 at 14:28
  • How did you try to delete? – David Foerster Feb 6 '17 at 8:56
  • Fron inside PCmanFM, which is the file manager from Lubuntu, on a share that was mounted via samba. – Ben Feb 6 '17 at 15:09
11

Because I did not find a lot on the internet about it I wanted to share my solution and keep the german original error message, which is "Löschprotokolldatei konnte nicht angelegt werden".

Somehow, the (hidden) folder SHARENAME/.Trash-1000 was owned by a different user than the one I used when connecting to the share. As soon as I fixed this on the NAS (over ssh) with sudo chown -R USER:GROUP FOLDER I was able to delete again from inside my filemanager that was connected to the share.

  • 2
    On some systems, the -R flag in chown must be capitalized, or it'll error out about -r not being proper usage. – Dooley_labs Jan 17 '17 at 12:09
  • thanks, I might have twisted it with 'cp -r'. Corrected it in the answer. – Ben Jan 17 '17 at 13:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.