1

I am on 16.04. I installed python 3.6.0 to /opt/python3.6 (it is not on my path) and when I try to run apt-get upgrade it tells me that I have a lot of unmet dependencies that depend on python <= 2.8 but 3.6.0-1 is installed...

for example...

 python-cffi-backend : Depends: python (< 2.8) but 3.6.0-1 is installed

but I don't see how this is affecting apt-get upgrade because the python3.6 is not in my path... I can verify that python --version outputs 2.7.12 and python3 --version ooutputs 3.5.2 which is what ships with ubuntu.

So how is this out-of-path 3.6 install affecting upgrades?

EDIT (output of apt-cache policy python):

python:
  Installed: 3.6.0-1
  Candidate: 3.6.0-1
  Version table:
 *** 3.6.0-1 100
        100 /var/lib/dpkg/status
     2.7.11-1 500
        500 http://mirrors.digitalocean.com/ubuntu xenial/main amd64 Packages
  • 1
    What is the output of apt-cache policy python? – muru Jan 17 '17 at 6:05
  • @muru, added to post. It seems to be finding it but IDK how – deltaskelta Jan 17 '17 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.