0

I removed the https in some links on this post because I was only allowed to put two links in this post.

Hello everyone! I just joined the Ubuntu family and I am currently loving it! But sadly I have had some trouble when I try to install packages from repositories, been looking all over for a solution, but nothing has worked for me. Basically I do the standard procedure,

sudo add-apt-repository "repo name here"
sudo apt-get update
sudo apt-get install "package name here"

I give you guys a more direct example with the log from when I tried to install MacBuntu.

sudo add-apt-repository ppa:noobslab/macbuntu
 This PPA is dedicated to Macbuntu transformation pack for Ubuntu.
 More info: https://launchpad.net/~noobslab/+archive/ubuntu/macbuntu
Press [ENTER] to continue or ctrl-c to cancel adding it
gpg: keyring `/tmp/tmpjb3pxpey/secring.gpg' created
gpg: keyring `/tmp/tmpjb3pxpey/pubring.gpg' created
gpg: requesting key F59EAE4D from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpjb3pxpey/trustdb.gpg: trustdb created
gpg: key F59EAE4D: public key "Launchpad PPA for NoobsLab" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK

I think this step is working normally, I believe something goes wrong in the following step.

sudo apt-get update

Returned these errors

sudo apt-get install macbuntu-os-icons-lts-v8
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package macbuntu-os-icons-lts-v8

If anyone knows whats wrong I'd really appreciate some help! I checked MacBuntu's website to make sure the repository was still there and tried cleaning my apt-get cache. Don't know what else to do.

  • 1
    Tualatrix PPA is dead. It can be used up to Ubuntu 14.04 only. You should remove it ASAP. This, however, shouldn't have interfered with others. Try again after removing Tualatrix PPA. – user589808 Jan 16 '17 at 23:02
0

For Xenial, you need to install macbuntu-os-icons-lts-v7.

Synaptic is another good way to install software... you can see all of the filenames, search, etc.

To solve the errors that occurred during sudo apt-get update, either use Software & Updates, choose the Other Software tab, and remove the tualatrix items, or do the following:

In terminal...

  • cd /etc/apt # change to the appropriate directory
  • grep tualatrix sources.list # search the file
  • if you find any, edit them out, gksudo gedit sources.list
  • cd /etc/apt/sources.list.d # change to another directory
  • grep tualatrix *.list # search these files
  • if you find any, delete that .list file, sudo rm filename.list
  • Please remember to vote/accept my answer if it was helpful. – heynnema Jan 17 '17 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.