14

All of a sudden when I try top open chrome on ubuntu, I get this message: enter image description here

Then when I click OK it opens without my profiles. I have now deleted all profiles, and uninstalled, purged, and reinstalled chrome and it keeps happening.

Anybody else having this problem?

chrome: Version 55.0.2883.87 unknown (64-bit)

ubuntu: Ubuntu 16.04.1 LTS

  • When you reinstall Google Chrome, try deleting the ~/.config/google-chrome/ folder too before reinstalling. All extensions for Chrome are stored in ~/.config/google-chrome/Default/Extensions/. – Terrance Jan 16 '17 at 15:07
  • yes I uninstalled, purged, deleted the google-chrome directory, reinstalled, started chrome from the command line, and then closed it and started it again and got the message again. – Alex028502 Jan 16 '17 at 16:57
  • One other thing I can think of would be to check your extensions one-by-one from chrome://extensions/ in the Chrome browser till you find the culprit that is not loading properly. – Terrance Jan 16 '17 at 17:21
  • The problem is when chrome does open after the pop-up, it opens a completely different profile, without any extensions. There are lots of extensions in the folder, but I guess they are the default ones because it is a new installation. – Alex028502 Jan 16 '17 at 17:55
  • Related: stackoverflow.com/questions/12533661/… – Elder Geek Jan 31 '17 at 19:06
14

After finally fixed it by deleting all the .desktop entries for chrome.

find ~ -name "*chrome*.desktop"
#and then after looking at the list and maybe looking inside the files and deciding
#that you are ok with deleting them just to see if this fixes it....
find ~ -name "*chrome*.desktop" | xargs rm
#or something like
find ~ -name "*chrome*.desktop" | xargs gvfs-trash
#or maybe just save them in a folder or rename them while you make sure
#this is the problem

I can't reproduce the situation so I can't tell you for sure if this was it, but it might be worth a shot if you have the same problem.

2

Had the same problem. This is how I fixed it:

apt-get remove google-chrome-stable
export CHROME_VERSION="google-chrome-stable"
wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add - 
echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google-chrome.list
apt-get update -qqy
apt-get -qqy install ${CHROME_VERSION:-google-chrome-stable}
rm /etc/apt/sources.list.d/google-chrome.list
rm -rf /var/lib/apt/lists/* /var/cache/apt/*
  • I was wrong, start from console did the job... – ANDY Jan 31 '17 at 17:40
  • This answer would be better if you annotated what each line does. – k-den Feb 7 '17 at 0:21
  • After performing these steps chrome started working. – Mindaugas Bernatavičius Dec 20 '17 at 13:36
2

I ran into this problem as a result of an incompletely installed extension. The extension, chromium-lwn4chrome, was installed through aptitude. I've got no idea how some of its files ended up not being installed.

I finally found it by running

strace -ochromium.strace chromium

In the chromium.strace file, I searched for the string "anifest" and found the lines

 lstat("/usr/share/chromium/extensions/lwn4chrome", 0x7ffd0c3bc520) = -1 ENOENT (No such file or directory)
 access("manifest.json", F_OK) = -1 ENOENT (No such file or directory)

Searching for lwn4chrome, I found

 open("/etc/chromium.d/lwn4chrome", O_RDONLY) = 3

Investigating that file, I found

export CHROMIUM_FLAGS="$CHROMIUM_FLAGS --load-extension=/usr/share/chromium/extensions/lwn4chrome"

but there was no file or directory named /usr/share/chromium/extensions/lwn4chrome on my system. I purged the chromium-lwn4chrome package, and the problem went away. I then reinstalled it (because I was curious) and this time everything worked.

1

I solved it opening chrome and navigating to chrome://version/

It showed me the following:

Chromium: 71.0.3578.98 (Versão oficial) snap 64 bits
Revisão: 15234034d19b85dcd9a03b164ae89d04145d8368-refs/branch-heads/3578@{#897}
SO: Linux
JavaScript: V8 7.1.302.31
Flash: (Desativada)
Agente do usuário: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) snap Chromium/71.0.3578.98 Chrome/71.0.3578.98 Safari/537.36
Linha de comando: /snap/chromium/562/usr/lib/chromium-browser/chrome --no-default-browser-check --no-first-run --password-store=basic --ppapi-flash-path --flag-switches-begin --flag-switches-end
Caminho do executável: /snap/chromium/562/usr/lib/chromium-browser/chrome
Caminho de perfil: /home/wagner/snap/chromium/562/.config/chromium/Default

the last line above is my PROFILE PATH

Pay attention on the last line which you need to point to your profile path. You need to set the ExperimentalOption to false as well. I set my ChromeOptions like this:

ChromeOptions options = new ChromeOptions();
options.addArguments("disable-infobars");
options.setExperimentalOption("useAutomationExtension", false);
options.addArguments("user-data-dir=/home/wagner/snap/chromium/562/.config/
chromium/Default");


driver = new ChromeDriver(options);

Enjoy!

0

This may be caused by not completely deleted Chrome/Chromium. I faced this issue when tried to launch Jupyter Notebook after reinstalling Chromium. In similar case next steps may help^

# Show all .desktop entries of Chrome/Chromium
find ~ -name "*chrom*.desktop"

# Delete them
find ~ -name "*chrom*.desktop" | xargs rm
0

Here is what I did to resolve this issue: 1. run this command to find all chrome*.desktop files. $ sudo find ~ -name "chrome.desktop"

the output in my computer:

/home/thachhoangn/.gnome/apps/chrome-apdfllckaahabafndbhieahigkjlhalf-Profile_1.desktop
/home/thachhoangn/.gnome/apps/chrome-blpcfgokakmgnkcojhhkbfbldkacnbeo-Profile_1.desktop
/home/thachhoangn/.gnome/apps/chrome-aohghmighlieiainnegkcijnfilokake-Profile_1.desktop
/home/thachhoangn/.gnome/apps/chrome-pjkljhegncpnkpknbcohdijeoejaedia-Profile_1.desktop
/home/thachhoangn/.gnome/apps/chrome-fhbjgbiflinjbdggehcddcbncdddomop-Profile_1.desktop
/home/thachhoangn/.local/share/applications/google-chrome.desktop
/home/thachhoangn/.local/share/applications/chrome-apdfllckaahabafndbhieahigkjlhalf-Profile_1.desktop
/home/thachhoangn/.local/share/applications/chrome-blpcfgokakmgnkcojhhkbfbldkacnbeo-Profile_1.desktop
/home/thachhoangn/.local/share/applications/chrome-aohghmighlieiainnegkcijnfilokake-Profile_1.desktop
/home/thachhoangn/.local/share/applications/chrome-pjkljhegncpnkpknbcohdijeoejaedia-Profile_1.desktop
/home/thachhoangn/.local/share/applications/chrome-fhbjgbiflinjbdggehcddcbncdddomop-Profile_1.desktop

As you see, those chrome*.desktop files are located in 2 directories.
/home/thachhoangn/.gnome/apps/ and /home/thachhoangn/.local/share/applications/

Now, list all files in these directories and take a look on the modified date time of files:

thachhoangn@thachhoangn ~ $ ll /home/thachhoangn/.gnome/apps/
total 32
drwx------ 2 thachhoangn thachhoangn 4096 Nov 15 01:14 ./
drwx------ 3 thachhoangn thachhoangn 4096 Jul 26 16:22 ../
-rw------- 1 thachhoangn thachhoangn 344 Oct 8 09:36 chrome-aohghmighlieiainnegkcijnfilokake-Profile_1.desktop
-rw------- 1 thachhoangn thachhoangn 352 Oct 17 07:34 chrome-apdfllckaahabafndbhieahigkjlhalf-Profile_1.desktop
-rw------- 1 thachhoangn thachhoangn 347 Oct 8 09:36 chrome-blpcfgokakmgnkcojhhkbfbldkacnbeo-Profile_1.desktop
-rw------- 1 thachhoangn thachhoangn 332 Nov 15 01:14 chrome-fhbjgbiflinjbdggehcddcbncdddomop-Profile_1.desktop
-rw------- 1 thachhoangn thachhoangn 345 Oct 8 09:36 chrome-pjkljhegncpnkpknbcohdijeoejaedia-Profile_1.desktop
-rw------- 1 thachhoangn thachhoangn 325 Jul 30 12:03 jetbrains-pycharm.desktop

thachhoangn@thachhoangn ~ $ ll /home/thachhoangn/.local/share/applications/
total 112
drwx------ 2 thachhoangn thachhoangn 4096 Dec 12 09:51 ./
drwx------ 20 thachhoangn thachhoangn 4096 Dec 11 19:32 ../
-rw------- 1 thachhoangn thachhoangn 328 Oct 8 09:36 chrome-aohghmighlieiainnegkcijnfilokake-Profile_1.desktop -rw------- 1 unifiedqe4 unifiedqe4 981 Dec 11 16:03 google-chrome.desktop
-rw------- 1 thachhoangn thachhoangn 336 Oct 17 07:34 chrome-apdfllckaahabafndbhieahigkjlhalf-Profile_1.desktop
-rw------- 1 thachhoangn thachhoangn 331 Oct 8 09:36 chrome-blpcfgokakmgnkcojhhkbfbldkacnbeo-Profile_1.desktop
-rw------- 1 thachhoangn thachhoangn 316 Nov 15 01:14 chrome-fhbjgbiflinjbdggehcddcbncdddomop-Profile_1.desktop
-rw------- 1 thachhoangn thachhoangn 329 Oct 8 09:36 chrome-pjkljhegncpnkpknbcohdijeoejaedia-Profile_1.desktop
-rw------- 1 thachhoangn thachhoangn 309 Jul 30 12:03 jetbrains-pycharm.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 283 Dec 11 16:03 mimeapps.list
-rw-rw-r-- 1 thachhoangn thachhoangn 813 Nov 15 09:34 mimeinfo.cache
-rw-rw-r-- 1 thachhoangn thachhoangn 311 Nov 12 15:36 wine.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 213 Nov 15 09:34 wine-extension-chm.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 220 Nov 15 09:34 wine-extension-gif.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 215 Nov 15 09:34 wine-extension-hlp.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 213 Nov 15 09:34 wine-extension-htm.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 227 Nov 15 09:34 wine-extension-ini.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 223 Nov 15 09:34 wine-extension-jfif.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 222 Nov 15 09:34 wine-extension-jpe.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 236 Nov 15 09:34 wine-extension-msp.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 247 Nov 15 09:34 wine-extension-ndm.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 218 Nov 15 09:34 wine-extension-pdf.desktopv -rw-rw-r-- 1 thachhoangn thachhoangn 220 Nov 15 09:34 wine-extension-png.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 210 Nov 15 09:34 wine-extension-rtf.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 205 Nov 15 09:34 wine-extension-txt.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 228 Nov 15 09:34 wine-extension-url.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 218 Nov 15 09:34 wine-extension-vbs.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 216 Nov 15 09:34 wine-extension-wri.desktop
-rw-rw-r-- 1 thachhoangn thachhoangn 218 Nov 15 09:34 wine-extension-xml.desktop

Based on modified datetime, you can try to delete one of those files that recently edited. Each time deleted a file, open chrome to check if the issue is gone.
I deleted 2 files : chrome.desktop, google-chrome.desktop which modified recently and it resolves the issue.
Hope this helps.

0

I solved a similar issue in my UBUNTU 18 OS this way, after I looked here:

1) I uninstalled chromium by writing in the terminal-

snap remove chromium

2) I installed "Chromium Web Browser" instead. Then it simply worked!

Details: It seems i didn't have a ~/.config/google-chrome/ directory. as chromium was a snap version. it was probably not supported by the ChromeDriver. cleaning the snap version and going to "Chromium Web Browser" made the magic work.

0

Procceed as follows:

  • Open the terminal Ctrl + Alt + T.
  • Type nautilus.
  • Go to the folder opt.
  • Find the folder named google and rename it to google_old.
  • Restart your system.
  • Install Chrome again.

That should resolve your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.