1

I have a Lenovo x260 that, after being plugged into a dock, and then being suspended (by closing lid), it does not wake up from suspend.

On opening the lid, the power light (and the logo light on the lid) come lit and stay lit, and the CPU fan starts to operate, however the screen remains blank. I've tried various key combinations (ctrl-alt-del, ctrl-alt-backspace, ctrl-alt-esc, ctrt-alt-f1-f7, alt-sysreg-f, alt-sysreg-reisub) and none of them have any effect whatsoever. System does not respond to ping over the wired network interface. The function lock light does activate. The only solution is to hold the power button down until the system is hard shutdown, and then restart.

If the laptop goes to sleep while docked, and is woken up while still docked, everything works fine. If the laptop is removed from the dock and then put into suspend (via lid shut), then it fails to wake up as described above. When not using a dock, the laptop has no issues with repeated suspend/wake cycles, both as a result of the lid being closed and suspend after inactivity as per power settings.

Details of the system are:

  • Ubuntu 16.04.1 quite fresh install
  • Intel graphics drivers installed using the "Intel Graphics Update Tool for Linux* OS"
  • additional drivers enabled, "Using processor microcode firmware for the intel CPUs from intel-microcode (proprietary)"
  • secure boot is disabled
  • bios virtualisation options are enabled
  • Intel i7-6500u processor, 16gb ram, 512gb SSD
  • have installed power management packages ?? but not done any custom configuration. Installed these before the dock arrived
  • Kernel has not been upgraded in any way, so just running default kernel for this release.
  • Dock is a Lenovo Thinkpad Ultra Dock 170W, connects via the custom dock connector on the bottom of the laptop.
  • Dock is driving two 1080p screens via Display Port, and built in screen displays at the same time.
  • wired network, usb keyboard/mouse are plugged into the dock.
  • wifi is turned on and usually is also connected

Anyone else have this issue? Any suggestions for fixing it, or otherwise performing further diagnostics to help in identifying the problem?

UPDATE - some further symptoms observed:

  • BIOS was updated from v1.23 to v.125. no change
  • tested with presence of USB devices and wired network connection to the dock - no difference
  • if external displays (two, connected to dock via displayport) are removed, problem ceases

Leads me to believe this is either a video driver issue, or some sort of firmware issue with the dock (it seems there is a firmware update available, however to install it a windows computer is required, which I don't have access to)

  • I am affected by this issue as well (both on x240 and x250). Thinkwiki.org's page about the dock has a link to a firmware upgrade that addresses some issues with display port (I haven't read further). Have you tried that? (thinkwiki.org/wiki/ThinkPad_Ultra_Dock) - UPDATE: I have just read the last sentence on your question... never mind. I will try updating the firmware later and will post the results. – romaia Feb 15 '17 at 11:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.