0

I am using Ubuntu 16.04 LTS and Gnome Unity UI.

Every time I use an application like PHPStorm or other dark applications the brightness goes down. When I go back to Google Chrome for example, and I look at a white page slowly it gets brighter.

When I try to force brightness with the keyboard it says it's at the max.

So, why do I have this issue? Is there a way to correct this?when I am on Facebook. Maybe it's related?

I also get things flashing on Google Chrome especially

I have a Dell laptop XPS 13. Intel® Kabylake GT2

  • Hi! Did you solve this problem? – Михаил Павлов Jul 22 '17 at 21:36
  • @МихаилПавлов No. I contacted Dell. They told me it was a firmware issue. And that I had to send my laptop to them to get a new one without this issue; "feature". – jnbdz Aug 2 '17 at 20:10
0

Late answer, but this issue is due to a "feature" of the intel graphics card used in these laptops. The "feature" is called Dynamic Contrast Enhancement, causing the brightness adjustment you describe. Most people find this undesirable, but the feature has also a benefit of saving battery power.

Dell has released a Windows only driver that allows turning this off. Linux users are left in the cold, though, even if these Dells can be purchased with Linux preinstalled. The only way to turn the feature off would be to (temporarily) install Windows and turn it off through the settings interface of the Windows driver.

  • Could it work with Windows running on a VM like VirtualBox? – jnbdz Jun 30 '18 at 20:55
  • Obviously not because the driver needs access to your real hardware. – vanadium Jul 2 '18 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.