0

My wifi was working just fine for a couple of days, but just now I suspended for dinner, when I came back I couldn't get my home wifi connect, it just keeps trying to connect, failing, then trying again. I restarted my pc and it didn't help. I can still use my wifi hotspot from my phone, it's only my home wifi that doesn't work. This is not the first time this has happened, and last time it just started working again after a while of messing with it. If you need the output from any command to help diagnose my problem, just ask, I'll be watching.

$ ifconfig
eth0      Link encap:Ethernet  HWaddr d8:50:e6:1a:8b:9c  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2260 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2260 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:186632 (186.6 KB)  TX bytes:186632 (186.6 KB)

wlan0     Link encap:Ethernet  HWaddr 24:0a:64:a1:eb:6a  
          inet addr:192.168.43.77  Bcast:192.168.43.255  Mask:255.255.255.0
          inet6 addr: fe80::260a:64ff:fea1:eb6a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16563 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14856 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:16752123 (16.7 MB)  TX bytes:3175005 (3.1 MB)

$ lspci -nnk | grep 0280 -A2
01:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: AzureWave Device [1a3b:1186]
    Kernel driver in use: ath9k

result of sudo iwlist wlan0 scan posted here: http://paste.ubuntu.com/23807847/

  • Please edit your question to add the result of: lspci -nnk | grep 0280 -A2 Welcome to Ask Ubuntu. – chili555 Jan 16 '17 at 0:03
  • output posted for lspci -nnk | grep 0280 -A2 – Guinevere Ellen Mayberry Jan 16 '17 at 0:06
  • Also: sudo iwlist wlan0 scan As the result may be lengthy, please paste it here and give us the link: paste.ubuntu.com – chili555 Jan 16 '17 at 0:11
  • post updated with sudo iwlist wlan0 scan results – Guinevere Ellen Mayberry Jan 16 '17 at 0:26
2

Please see:

Cell 01 - Address: A0:91:69:C1:4B:47
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=70/70  Signal level=-36 dBm  
                    Encryption key:on
                    ESSID:"Fox Goddess"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000000be9a8daa
                    Extra: Last beacon: 60ms ago
                    <snip>
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

Your driver and old Chili hate hate hate TKIP.

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

Any improvement?

  • editing my router settings is not an option, as it's not my router (I live with family). I tried the rest of your suggestion but no change. – Guinevere Ellen Mayberry Jan 16 '17 at 1:11
  • for the record, the router security is set to WPA & WPA2 Personal – Guinevere Ellen Mayberry Jan 16 '17 at 1:18
  • well all of a sudden it connected again, so I guess I'll mark it answered for now and return if it messes up again. – Guinevere Ellen Mayberry Jan 16 '17 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.