2

I've recently purchased an Asus E202S desktop computer and tried to install Ubuntu 16.04 on it. I had no problems to install or make a dualboot with Windows 10, but the real problems started to show up almost an hour after I've finished the system installation.

Basically, my wifi is periodically "freezing" (The wifi signal shows that everything is ok, but I do not have Internet connection), and I am forced to restart the network-manager. Even after restarting the manager, sometimes my wifi won't show up on the list of available networks or will not work at all. I don't have any of these problems on Windows 10, and also my Internet speed is much faster.

I've been trying to find the problem for almost one week, and here are some of the dozens of cases which seemed to be the closest to mine:

 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1482979
 http://askubuntu.com/questions/730430/wifi-connection-keeps-dropping-in-ubuntu-15-10-rtl8821ae
 https://ubuntuforums.org/showthread.php?t=2245164
 http://askubuntu.com/questions/797213/wireless-disconnect-issues-ubuntu-16-04-with-rtl8821ae
 http://askubuntu.com/questions/730430/wifi-connection-keeps-dropping-in-ubuntu-15-10-rtl8821ae

Even though I could find several people that had the same problem that I'm having, their solutions did not do me any good, and as a newbie ubuntu user, I'm not sure about how I should proceed in this situation.

Problem affects immediately if I uploading information like on Dropbox or via "scp" file transfer. When freezing, ping command answer:

 ping: sendmsg: No buffer space available

My wireless information: https://paste.ubuntu.com/23806837/

Also I've tried:

a.)

  sudo add-apt-repository ppa:hanipouspilot/rtlwifi
  sudo apt-get update
  sudo apt-get install rtlwifi-new-dkms

It makes connection a little bit stable, with this driver I can upload 30-40 mb instead of only 5mb, but after upload freezes again.

b.) If I boot with older kernel (3.19.8) networking is working perfect and two times faster. But!, only in shell because Xorg fail to start on this kernel with error:

 [   113.698] 003f:1bdf: 3F ILLEGAL EXTENDED X86 OPCODE!
 [   113.698] (II) VESA(0): Setting up VESA Mode 0x17F (1366x768)
 [   113.698] 0000:1fcf: 3F ILLEGAL EXTENDED X86 OPCODE!
 [   113.698] (II) VESA(0): VBESetVBEMode failed0000:1fcf: 3F ILLEGAL EXTENDED X86 OPCODE!
 [   113.698]
 [   113.698] (EE)
 Fatal server error:
 [   113.699] (EE) AddScreen/ScreenInit failed for driver 0
 [   113.699] (EE)

Can anyone help me to solve these issues?

6
  • Welcome to Ask Ubuntu! Please run this script and edit your post with the output, preferebly on Ubuntu pastebin – M. Becerra Jan 15 '17 at 20:51
  • Do not use mixed mode, use WPA2 only. – user589808 Jan 15 '17 at 21:53
  • My router configured only for WPA2. Where I should turn off mixed mode? – Viktoria Fesenko Jan 15 '17 at 21:59
  • According to chili555's answer there's currently no way to improve the situation unless you can find someone to write a better driver. He's by far the most knowledgeable here when it comes to wireless adapter drivers and you're unlikely to get a better answer on AskUbuntu. However, the answer is almost a year old. If you can draw his attention to your question he may reinvestigate the situation and check if anything changed for the better during that time. – David Foerster Jan 15 '17 at 22:42
  • I wrote him a message in chat asking if he knows anything new. If he decides to take a look he'll comment or answer on your question. – David Foerster Jan 15 '17 at 23:02
0

RTL8821AE wifi drivers in Ubuntu 16.04 First thing first, you need to identify which device is being used in your hardware, to find it, I opened a terminal and wrote the following:

lspci | grep Wireless

The system replies with the following line 03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter The model of the device (RTL8821AE) is very important, we will come back to this later. For some reason, realtek adapters have had a history of disconnects and signal drops, but, lucky for us there is an answer.

sudo apt-get install linux-headers-generic build-essential git 
git clone http://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install

These commands build and install the drivers for rtl8192ce, rtl8192se, rtl8192de, rtl8188ee, rtl8192ee, rtl8723ae, rtl8723be, and rtl8821ae, all in one go. Just in case the system doesn’t load the appropriate kernel module, you can execute the following command from within your rtlwifi_new directory

sudo modprobe rtl8821ae

and reboot your system. Congratulations your Ubuntu Linux kernel now has working Realtek wireless drivers.

0

It's a 16.04 kernel's bug. You can upgrade to 16.04.2, that use the kernel 4.8.x (that resolve the bug).

Using the command

sudo apt install --install-recommends linux-generic-hwe-16.04

or, if you would upgrade all the xserver subsystem, the command

sudo apt install --install-recommends xserver-xorg-hwe-16.04
0

I hav ASUS E202S & The problem is not the driver RTL8821AE, the problem is the NetWork Manager. As say in https://github.com/lwfinger/rtlwifi_new/issues/185 if you change Network Manager by wicd Wireless network manager the problem disappear.

"[...]

Finally solved my rtl8821ae connection issue solution:

1- open /etc/NetworkManager/NetworkManager.conf as root and disable the Network Manager for your wireless interface adding these lines

[keyfile]
unmanaged-devices=mac:b3:e40:92:68:b1:33

REMEMBER TO USE LOWERCASE and replace with your wireless mac address

2-install wicd network manager

sudo apt-get install wicd

reboot "

1
  • I can confirm: This recommended solution works on my machine, and the problem went away. – Ali Dec 26 '17 at 16:54
-1

In addition to Kirill's excellent answer on updating the rtl8821ae driver, you may need to update your kernel using

sudo apt-get upgrade; sudo apt install --install-recommends linux-generic

Then replace the NetworkManager by WICD https://help.ubuntu.com/community/WICD

These steps finally solved my nagging wifi problem in 16.04 that bugged me for months (i had used ubuntu since 2005, but this nasty wifi bug almost made me stop using ubuntu altogether. it was quite a relief that the above steps finally got rid of my wifi trouble. hope they may help to solve your problem as well)

-3

I used the following steps from Ubuntu Forums, which appeared to solve my equivalent problem:

I also have a realtek wifi card and had issues with the network stopping until I disabled IPv6. Since doing that it works fine. Go to your network's properties,go to theIPv6 tab and select Ignore from the dropdown menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.