0

When attempting to plot graphs in python 2.7 using matplotlib or Octave the program stalls and needs to be closed. Octave gives the following errors on startup:

No protocol specified octave: unable to open X11 DISPLAY octave: disabling GUI features No protocol specified

If I run plot(x,y) the program stalls and on pressing Ctrl-C the following appears.

gnuplot: unable to open display ':0' gnuplot: X11 aborted.

I have tried many online suggestions such as setting X11Forwarding to yes (which it already was), and running startx which leaves me with a blank screen with a cross cursor and changing DISPLAY to numerous things, among others.

UPDATE: When I run xinit I get the following:

(EE) Fatal server error: (EE) Server is already active for display 0 If this server is no longer running, remove /tmp/.X0-lock and start again. (EE) (EE) Please consult the The X.Org Foundation support at http://wiki.x.org for help. (EE) XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0" after 7 requests (7 known processed) with 0 events remaining.

Not sure why I would need this or if it helps. Also in octave if I run 'setenv("DISPLAY")' then try to run a plot it still stalls but on canceling the terminal shows a blank screen with the forward, back and quit commands.

This is a new system and haven't had these problems with octave or python before.

OS: Ubuntu 16.10 Processor: AMD A10-8700P Radeon R6

  • So... you are running this remotely, via SSH? What is the local system? what X server is running on it? what SSH client are you using and is it configured for X11 forwarding (e.g. ssh -X)? – steeldriver Jan 15 '17 at 20:14
  • I'm running this locally on my machine, I'm not trying to use any ssh client. The xserver is xorg I believe. All I did was install octave as I normally would and on running this error occurs. – John Nathan Jan 15 '17 at 20:53
  • OK in that case I'm confused why X11Forwarding would come into the picture at all? You are not trying to run it as root (e.g. sudo octave) or from a CLI virtual terminal? is the display variable set in your session (echo $DISPLAY)? and octave was installed from the repository? – steeldriver Jan 15 '17 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.