2

First off, thank you to all the great questions and easy to follow how to(s) on this site. Great community answers here.
This is my first time using Ubuntu so I really need easy to follow directions.

My main issue is that this is a HTPC on a laptop and when I use the laptop and open and close the screen, my sound for HDMI switches to laptop speakers and not back. I have read some work arounds for this here but as I understand pulseaudio 9.0 has been released and fixes this issue.

So, how can I (hopefully easily) upgrade my Ubuntu from 8.0 to 9.0?

Is this a bad idea?

I'm running Ubuntu 16.04.1

0

The easiest method is to download the .deb file and install.

As you can see here, version +9.0 is available from official repositories (main) for both Ubuntu 16.10 and 17.04. Let's say you want to use the latest stable, for 17.04:

  1. Download the package from here, from the "Builds" subsection, according to your architecture. For this answer, I will assume you are using x86_64. The file is this one.
  2. In a terminal, run the following:

    sudo dpkg -i /path/to/pulseaudio_9.0-5ubuntu3_amd64.deb
    
  3. Now, to fix dependencies problems, run:

    sudo apt-get -f install
    

That's it.

Another, more complex method, is through Apt-Pinning. Check this or this. I can add a guide to the answer if you want, but the above method should be enough.

  • Thanks luchonacho... so follow up question(s)... is pulseaudio 9.0 included in Ubuntu 17.04? AND, if so can I just update my Ubuntu to 17.04? AND finally... if so, how? – Michael Jan 15 '17 at 17:57
  • 1
    Yes, it is included. But, since you only have a problem with audio, I suggest you just update Pulseaudio, as in my answer. That is enough, and much simpler. If you still want to move away from 16.04, I suggest 16.10. It will still give you Pulseaudio +9. You can find it here. Install as you installed 16.04 (probably with an ISO into a USB or CD). Check the tons of instructions available online if you are having trouble with that. – user308164 Jan 15 '17 at 18:14
  • I got the following error...dependency problems prevent configuration of pulseaudio: pulseaudio depends on libpulse0 (= 1:9.0-5ubuntu3); however: Version of libpulse0:amd64 on system is 1:8.0-0ubuntu3.1. – Michael Jan 16 '17 at 1:13
  • Version of libpulse0:amd64 on system is 1:8.0-0ubuntu3.1. pulseaudio depends on libwebrtc-audio-processing1; however: Package libwebrtc-audio-processing1 is not installed. pulseaudio depends on pulseaudio-utils; however: – Michael Jan 16 '17 at 1:16
  • Ok, that is because the libraries needed are not available in your version of Ubuntu. The option is then to use Apt-Pinning. Will update the answer shortly. – user308164 Jan 16 '17 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.