3

I have Xubuntu 16.10 with latest updates on my laptop. I have also have installed Debian 8.0, Manjaro, and Windows 7. All these OSs are controlled by GRUB bootloader from Xubuntu. I do all my tasks between Linux distros but occasionally switch over to Windows 7 for doing specific tasks. I have noticed strange behavior in the last two weeks. Whenever I boot in to Windows OS, do my tasks and reboot in to Xubuntu, I see this message:

^[[[B^[[[B^[[[Bfsck.ext4: Superblock checksum does not match superblock while trying to open /dev/sda2
/dev/sda2:
The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
 or
    e2fsck -b 32768 <device>

fsck exited with status code 8
[    9.100397] EXT4-fs (sda2): VFS: Found ext4 filesystem with invalid superblock checksum.  Run e2fsck?
mount: mounting /dev/sda2 on /root failed: Bad message
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /run on /root/run failed: No such file or directory
run-init: current directory on the same filesystem as the root: error 0
Target filesystem doesn't have requested /sbin/init.
run-init: current directory on the same filesystem as the root: error 0
run-init: current directory on the same filesystem as the root: error 0
run-init: current directory on the same filesystem as the root: error 0
run-init: current directory on the same filesystem as the root: error 0
run-init: current directory on the same filesystem as the root: error 0
No init found. Try passing init= bootarg.


BusyBox v1.22.1 (Ubuntu 1:1.22.0-19ubuntu2) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)

I have to fix this error by executing e2fcsk -b 32768 /dev/sda2. This occurs only when I boot into Windows first and Xubuntu next.

Additional note:- I used https://sourceforge.net/projects/ext2fsd/ to access Linux partitions from Windows. However, I have turned it off when I noticed this issue for the first time. Also the issue listed above only occurs on my Xubuntu partition and not for other Linux distros.

Edit 1:- What I intended by saying turned it off is that I removed from startup application while booting in to windows. I did not uninstall the software (ext2fsd). This did not solve the solve the problem as well. Also, as Rinzwind pointed out, I forced ext2fsd to work on read and write mode.

  • 2
    I doubt windows to be the problem. Microsoft does not recognize other filesystems. I would focus on either a problem in grub or the boot process of Ubuntu. Or a hardware problem. – Rinzwind Jan 15 '17 at 12:40
  • I don't think it as a grub issue. Why will the issue appear when booting ubuntu after returning windows. – sundar Jan 15 '17 at 13:52
  • You're focusing on the context of the occurrence and drawing misleading hypotheses whereas @Rizwind is arguing plausibility and I concur. However, I don't know ext2fsd, it may run as a service regardless of your using it or not. You mentioned turning it off... But not uninstalling it and if it runs as service it'll try to read the other partitions and may trigger the "invalid superblock checksum" especially if sda2 is somehow different. – user589808 Jan 15 '17 at 14:27
  • @ CelticWarrior misleading hypotheses. No I am not, as I was certain that it happed only after Windows boot. However I appreciate your correct appreciation of the possible cause. As you pointed out, the culprit turned out to be ext2fsd. I uninstalled the software and rebooted (of-course after correcting initial fail) to make it work. I am certain that this was the issue and tested not only once but thrice to confirm(booting to windows --> Ubuntu --> windows --> Ubuntu --> and windows --> Ubuntu). You can post it as solution for me to accept. – sundar Jan 15 '17 at 15:25
  • @sundar " Ext2Fsd has limited EXT4 support and by default it will load the filesystems in read-only mode, but you can force this if you really have to write on EXT4 partitions from Windows (this is not recommended). Using it, your EXT partitions will be displayed just like native NTFS or FAT partitions, being accessible from Windows Explorer." Don't use it for unsupported features please. – Rinzwind Jan 15 '17 at 22:11
4

Microsoft Windows, by default, does not recognize other file systems. It would be impossible for Windows alone to cause the error.

However, you installed ext2fsd, a tool to enable read/write in EXT partitions from Windows. This software often runs as a service and mounts partitions at boot, hence accessing Ubuntu partitions.

ext2fsd may not be fully compatible with newer EXT4 file systems or have other issues or Ubuntu may have been installed with partitions settings the Windows tool can't understand, either way resulting in the "invalid superblock checksum" error.

The solution is uninstall ext2fsd.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.