0

I have installed onedrive-d, since terminal, But when I want to start it, with "onedrive-d start" command, terminal gives me next error:

Traceback (most recent call last):
  File "/usr/local/bin/onedrive-d", line 11, in 
    load_entry_point('onedrive-d==1.1.0.dev0', 'console_scripts', 'onedrive-d')()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 565, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2589, in load_entry_point
    return ep.load()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2249, in load
    return self.resolve()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2255, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "", line 969, in _find_and_load
  File "", line 958, in _find_and_load_unlocked
  File "", line 664, in _load_unlocked
  File "", line 634, in _load_backward_compatible
  File "/usr/local/lib/python3.5/dist-packages/onedrive_d-1.1.0.dev0-py3.5.egg/onedrive_d/od_main.py", line 9, in 
  File "", line 969, in _find_and_load
  File "", line 958, in _find_and_load_unlocked
  File "", line 664, in _load_unlocked
  File "", line 634, in _load_backward_compatible
  File "/usr/local/lib/python3.5/dist-packages/daemonocle-1.0.1-py3.5.egg/daemonocle/__init__.py", line 9, in 
  File "", line 969, in _find_and_load
  File "", line 958, in _find_and_load_unlocked
  File "
    load_entry_point('onedrive-d==1.1.0.dev0', 'console_scripts', 'onedrive-d')()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 565, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2589, in load_entry_point
    return ep.load()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2249, in load
    return self.resolve()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2255, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "", line 969, in _find_and_load
  File "", line 958, in _find_and_load_unlocked
  File "", line 664, in _load_unlocked
  File "", line 634, in _load_backward_compatible
  File "/usr/local/lib/python3.5/dist-packages/onedrive_d-1.1.0.dev0-py3.5.egg/onedrive_d/od_main.py", line 9, in 
  File "", line 969, in _find_and_load
  File "", line 958, in _find_and_load_unlocked
  File "", line 664, in _load_unlocked
  File "", line 634, in _load_backward_compatible
  File "/usr/local/lib/python3.5/dist-packages/daemonocle-1.0.1-py3.5.egg/daemonocle/__init__.py", line 9, in 
  File "", line 969, in _find_and_load
  File "", line 958, in _find_and_load_unlocked
  File "", line 664, in _load_unlocked
  File "", line 634, in _load_backward_compatible
  File "/usr/local/lib/python3.5/dist-packages/daemonocle-1.0.1-py3.5.egg/daemonocle/cli.py", line 8, in 
AttributeError: module 'click' has no attribute 'MultiCommand'
trap>", line 664, in _load_unlocked
  File "", line 634, in _load_backward_compatible
  File "/usr/local/lib/python3.5/dist-packages/daemonocle-1.0.1-py3.5.egg/daemonocle/cli.py", line 8, in 
AttributeError: module 'click' has no attribute 'MultiCommand'

somebody can tell me what to do for fix the error? thank you so much!

1 Answer 1

0
  1. You should install daemonocle

    sudo pip install daemonocle
    
  2. You should use python-3.5 not the other Python version.

    ls -la /usr/bin/python3
    
    lrwxrwxrwx 1 root root      33  3月 28 16:37 /usr/bin/python3 -> /home/alex/.pyenv/shims/python3.5

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .