4

Problem:

As the title says; the keyboard mute button doesn't unmute audio, though the light does toggle and it has no problem muting it.

I've been using this notebook with Xubuntu 16.04 and I'm pretty sure it had no trouble, not sure if it's specific to Lubuntu or 16.10.

Software:

Lubuntu 16.10

Hardware

HP notebook pavilion dv6

Question:

Is there any way to fix it?

Thanks for your answers.

Extra info:

Posting question late at night, don't expect me to be awake till 8 hours later.

5

IMPROVED ANSWER:

See Mute button won't toggle / un-mute for how to add "-D pulse" to mute using the Preferences menu.

The following is how to adjust it by editing a configuration file:

Insert "-D pulse" as in the following lines, in .config/openbox/lubuntu-rc.xml

  <!-- Keybinding for Volume management -->
  <keybind key="XF86AudioRaiseVolume">
    <action name="Execute">
      <command>amixer -q -D pulse sset Master 3%+ unmute</command>
    </action>
  </keybind>
  <keybind key="XF86AudioLowerVolume">
    <action name="Execute">
      <command>amixer -q -D pulse sset Master 3%- unmute</command>
    </action>
  </keybind>
  <keybind key="XF86AudioMute">
    <action name="Execute">
      <command>amixer -q -D pulse sset Master toggle</command>
    </action>
  </keybind>

My previous answer doesn't work with sound from all pulse audio applications, such as playing YouTube in Firefox. The above answer works.

See SOLVED Can't unmute using amixer at Ubuntu forums for the sources of this improvement in the command.


My previous answer, for reference:


Open alsamixer in LXTerminal to see what sound controls get muted and unmuted when you press the mute button repeatedly. You might find that the mute button mutes "Master" and some other volume controls. You might find that using any mute in alsamixer (pressing the m key) mutes everything else.

To adjust what the keyboard mute button does, one way is to edit /home/[username]/.config/openbox/lubuntu-rc.xml

(If you don't have that file $HOME/.config/openbox/lubuntu-rc.xml you can make it by copying /usr/share/lubuntu/openbox/rc.xml to $HOME/.config/openbox/lubuntu-rc.xml )

I made comments out of the original commands for volume and mute controls there, and inserted my own commands. Now the section of my lubuntu-rc.xml titled "Keybinding for Volume management" looks like this:

<!-- Keybinding for Volume management -->

    <!-- sde  Whether using command amixer or alsamixer in lxterminal,
              setting any control to `mute` sets several other controls to
              mute, which don't get reset when setting Master to `unmute`
              (even when those settings are by `toggle`) -->

<keybind key="XF86AudioRaiseVolume">
  <action name="Execute">
    <!-- <command>amixer -q sset Master 3%+ unmute</command> -->
    <command>bash -c "amixer -q sset Master 1%+ unmute; amixer sset Front unmute; amixer sset Surround unmute; amixer sset Center unmute; amixer sset LFE unmute"</command>
  </action>
</keybind>
<keybind key="XF86AudioLowerVolume">
  <action name="Execute">
    <!-- <command>amixer -q sset Master 3%- unmute</command> -->
    <command>bash -c "amixer -q sset Master 1%- unmute; amixer sset Front unmute; amixer sset Surround unmute; amixer sset Center unmute; amixer sset LFE unmute"</command>
  </action>
</keybind>
<keybind key="XF86AudioMute">
  <action name="Execute">
    <!-- <command>amixer -q sset Master toggle</command> -->
    <command>bash -c "amixer -q sset Master toggle; amixer sset Front unmute; amixer sset Surround unmute; amixer sset Center unmute; amixer sset LFE unmute"</command>
  </action>
</keybind>

This works in Lubuntu 17.10 and should work in earlier versions too.

Run "amixer scontrols" to see what names of controls you can use for your own modifications.

Save a backup file for lubuntu-rc.xml so that you can replace it from a terminal if your changes go wrong, then restart lubuntu or openbox, to hear if your changes work.

(I know this isn't an easy adjustment, but it does answer whether it's possible to fix.)

0

I have the same problem with an emachines pentium machine running LXLE 16.04. I hit the keyboard mute button once and now I can't get any music at all, even after shutting down and rebooting the system.

Then I went to sound and video > pulse audio volume control and brought up that window. Then I clicked on output devices and down near the bottom is built-in audio analog stereo and a few icons to the right. Hover over them and find the mute audio one and click on it. That un-muted the sound for me. I will never press the mute button on my keyboard again.

  • 1
    I'm doing something similar, but that doesn't really answer the question... – Teivel Feb 15 '17 at 5:26
0

I solved it editing ~/.config/openbox/lubuntu-rc.xml

<keybind key="XF86AudioMute">
  <action name="Execute">
    <!-- <command>amixer -q sset Master toggle</command> -->
    <command>amixer -D pulse set Master toggle</command>
  </action>
</keybind>

And then update openbox settings for current session:

openbox --reconfigure

Worked for me on Lubuntu 17.10

More here: https://bugs.launchpad.net/ubuntu/+source/alsa-utils/+bug/1313813

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.