8

I've been trying to install Ubuntu for some time now, as a dual boot with Windows 10 on my XMG Schenker laptop. I have an Nvidia GTX 1060 graphics card, and i7 6700 CPU. I'm trying to install Ubuntu 16.10

The problem I'm experiencing is that I choose either "Install Ubuntu" or "Try Ubuntu without Installing" from the Bootable USB, I get a splash screen, and then the screen will flash once or twice, then freeze. The USB reading indicator will stop flashing, and the laptop's fans would slow down to minimum (0% CPU, I'm guessing).

At some point, I'll even hear the Ubuntu start-up sound (the one you get when getting to the login screen), and the keyboard is responsive (CAPS LOCK is working, I managed to restart by hitting the power button and navigating blindly with the keyboard)

I've seen the other posts like My computer boots to a black screen, what options do I have to fix it? and Graphics issues after/while installing Ubuntu 16.04/16.10 with NVIDIA graphics.

Here are my attempts:

  • Initially, I was trying to install Ubuntu GNOME, and got the same effect.
  • Setting nouveau.modeset=0 in the kernel options had no effect.
  • Adding nomodeset and/or removing quiet splash from the kernel options just made the splash screen disappear, and now I'm seeing a black screen, no terminal, no nothing.
  • At no point did I manage to get to a TTYL. Ctrl + Alt + 1 (or 2 or 3) had no effect.
  • Windows 10 boots just fine.

I'm lost. I'll be happy to provide more details upon request.

14
+150

First things first ... SCHENKER ships the same notebooks which are based on CLEVO barebones with Ubuntu preinstalled through their sub-company TUXEDO ... so it just must work somehow.
Second - of course you can't access a virtual console with this combination : Ctrl + Alt + 1 !

Even that I don't know the exact model you are having ... it is a quite new machine because it has the latest available graphics hardware. These new XMG machines have the option to disable the NVIDIA Optimus technology in the BIOS, which is what you should do until you have Ubuntu and the NVIDIA drivers successfully installed. Boot into BIOS and disable all NVIDIA related switches.

Now after having disabled Optimus in the BIOS, also disable Secure Boot in the UEFI settings.
This does not have any effect on Windows 10, it will boot in Secure Boot mode nevertheless.
Please follow exactly all of these instructions, most probably everything will work fine then.

Disable hibernation in Windows OS - open command prompt as administrator and execute :

powercfg /h off  

Disable Fast startup in Windows -> open the Windows Control Panel -> Power Settings and uncheck Fast startup. In case that the setting is not visible, enable Show hidden settings.
Shutdown the machine completely, do NOT reboot it, otherwise it always starts Windows.

Boot from the Ubuntu installation media you created ... select Try Ubuntu without installing.
Press the E key and add the parameter nouveau.modeset=0 at the end of the linux line.
Press the F10 key and boot into the Ubuntu Live desktop - start the installation of Ubuntu.

After it has finished boot into BIOS and select Ubuntu as the default system to boot.
You can select to boot Windows alternatively from the GRUB boot menu afterwards.

Now boot the successfully installed Ubuntu operating system, select the Ubuntu menu entry.
Press the E key and add the parameter nouveau.modeset=0 at the end of the linux line.
Press the F10 key and boot into the Ubuntu system to first of all install the NVIDIA drivers.

When the login screen appears press : Ctrl+Alt+F1
Enter your user name and the password, then execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt install nvidia-375 nvidia-prime
sudo reboot  

Boot into BIOS and enable the NVIDIA graphics with Optimus support - then boot the Ubuntu OS.
From now on you do not have to add the nouveau.modeset=0 parameter or any other parameter.

Notes : Set a Space between the last character in the linux line and nouveau.modeset=0.

Switch between intel and NVIDIA graphics from NVIDIA X Server Settings -> PRIME Profiles.

Additional information :

I am writing this on a XMG machine on which I installed Ubuntu 16.10 and the NVIDIA drivers. Another company that ships CLEVO based machines with Ubuntu preinstalled is system76 ...

4
  • Following this, I now get a terminal output when running the "Try without installing", and it gets stuck on the following error: Bluetooth: hci0: Setting Intel event mask failed (-16) – Madara's Ghost Jan 19 '17 at 20:46
  • Installing 16.04.1 instead of 16.10 with this guide helped. Although I haven't tried (and won't try, in the near future) upgrading to 16.10. – Madara's Ghost Jan 20 '17 at 9:12
  • @MadaraUchiha : You are having very new hardware ... some things have to settle down ... maybe once Ubuntu 17.04 is released, most of all drivers related problems will be sorted out. :) – cl-netbox Jan 20 '17 at 9:22
  • had the same problem with 16.04. found out that if you press f6 (for other options while selecting install or trying ubuntu) you can now also select nomodeset graphically – AdrianLoer Oct 7 '17 at 23:36
0

I had the same problem with my Xubuntu 18.04 version that runs on Nvidia GPU. I tried to installed the latest Nvidia-390 and nvidia-prime drivers and updated my driver installs as these solutions show [1] [2], and I added nouveau to the block list, but none of these worked. So what I did is that I added the parameternouveau.modeset=0 to grub.cfg file in \boot\grub\ directory. I added the line after every "linux..." line, for instance:

menuentry 'FAILSAFE' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    set gfxpayload=$linux_gfx_mode
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos8)'
    search --no-floppy --fs-uuid --set=root 36286167-4eba-4a1e-a202-155c6baafa01
    linux /boot/vmlinuz-2.6.37-12-generic root=UUID=36286167-4eba-4a1e-a202-155c6baafa01 ro vt.handoff=7 quiet splash nouveau.modeset=0
    initrd /boot/initrd.img-2.6.37-12-generic
    } 

So, I believe you have to add this parameter in all the script. I tried this solution and Nvidia GPU driver stopped crashing.

Another approach as described here

Execute sudo nano /etc/default/grub and add the parameter nvidia-drm.modeset=1 to the line GRUB_CMDLINE_LINUX_DEFAULT. Save the change you've made and run sudo update-grub.
Restart the Ubuntu operating system, and now, everything should work properly - right as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.