4

For a couple of weeks I am now experiencing problems with my trackpoint and touchpad on my Thinkpad T460p on Ubuntu 16.04. I am normally using trackpoint only, preferably with touchpad being disabled.

After a fresh install everything worked fine, probably because synaptics still managed the input devices instead of libinput.

After a kernel upgrade the scroll functionality was gone and sensitivity of touchpad and trackpoint was messed up. Manually switching back to an older kernel version fixed the problem.

Unfortunately I removed this kernel version via a thoughtless autoremove, and even after manually reinstalling this kernel version I could not get my pointing devices to work as before.

Now I am running on kernel 4.4.0-59-generic with libinput and synaptics installed. xinput is giving me:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Synaptics TouchPad                   id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=10   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=13   [slave  keyboard (3)]
    ↳ 00:0C:8A:7E:A5:23                         id=14   [slave  keyboard (3)]
    ↳ AT Raw Set 2 keyboard                     id=16   [slave  keyboard (3)]

So my trackpoint still works but is no longer recognized as such.

The settings of my touchpad show:

Device 'PS/2 Synaptics TouchPad':
    Device Enabled (139):   1
    Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Accel Speed (276): 0.000000
    libinput Accel Speed Default (277): 0.000000
    libinput Accel Profiles Available (278):    1, 1
    libinput Accel Profile Enabled (279):   1, 0
    libinput Accel Profile Enabled Default (280):   1, 0
    libinput Natural Scrolling Enabled (281):   0
    libinput Natural Scrolling Enabled Default (282):   0
    libinput Send Events Modes Available (260): 1, 0
    libinput Send Events Mode Enabled (261):    0, 0
    libinput Send Events Mode Enabled Default (262):    0, 0
    libinput Left Handed Enabled (283): 0
    libinput Left Handed Enabled Default (284): 0
    libinput Scroll Methods Available (285):    0, 0, 1
    libinput Scroll Method Enabled (286):   0, 0, 1
    libinput Scroll Method Enabled Default (287):   0, 0, 1
    libinput Button Scrolling Button (288): 2
    libinput Button Scrolling Button Default (289): 274
    libinput Middle Emulation Enabled (290):    0
    libinput Middle Emulation Enabled Default (291):    0
    Device Node (263):  "/dev/input/event6"
    Device Product ID (264):    2, 1
    libinput Drag Lock Buttons (292):   <no items>h
    libinput Horizonal Scroll Enabled (265):    1

I can change the pointer speed via xinput --set-prop which takes effect on touchpad and trackpoint. But even maximum speed is too slow on the trackpoint. I can disable the touchpad but that also disables the trackpoint, and although the libinput 'Palm Detection' is enabled I frequently perform random clicks while typing, which is very annoying.

So it seems like trackpoint and touchpad are recognized as one pointing device with limited functionality (e.g. only On-Button Scrolling).

I only want a fast trackpoint and a disabled touchpad. So I guess the options are:

  1. Getting the system to use synaptics instead of libinput (simply removing libinput does not work unfortunately)
  2. Getting libinput to recognize touchpad and trackpoint correctly
  3. Something I did not think of

Any ideas?

0

For anyone with an external keyboard with a trackpoint, I opened up the keyboard, lifted up the film to look for any obvious signs of damaage, didn't see any and put it back together and the problem was solved. I guess maybe there was static that removing the film discharged or something else wrong which removing the film fixed.

We'll see if the issue returns.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.