This question already has an answer here:

I'm using Ubuntu GNOME 16.10 and was trying to install WPS Office. I tried to install using software centre But it wasn't installing without giving any error logs. Then I opened it with Gdebi installer. Here is what I saw.

shows erorr

I have already trying enabling multiverse repositories.

Edit:
I have downloaded the amd64 package from the WPS official site, but even now installing through terminal I still get the missing dependencies error.

marked as duplicate by David Foerster, Eric Carvalho, Yaron, Zanna, pa4080 Sep 11 '17 at 20:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have tried using the .deb files from here ? To install use sudo dpkg -i package_name – George Udosen Jan 14 '17 at 15:12
  • @George yes i have tried, still in the terminal, it shows.... dpkg: dependency problems prevent configuration of wps-office: wps-office depends on libpng12-0; however: Package libpng12-0 is not installed. – Alan Jameson Jan 14 '17 at 15:29
  • 1
    the problem is that libpng12-0 is only present in the repositories until Ubuntu 16.04 LTS! - i don't know why and can't tell you how, but you will need libpng12-0 to install WPS Office. – DJCrashdummy Jan 14 '17 at 15:47
  • 1
    @DJCrashdummy Oh thx that solved the problem. – Alan Jameson Jan 14 '17 at 16:03
  • 1
    Or you can download the xenial version directly here: packages.ubuntu.com/xenial/libpng12-0 (install it before attempting to install WPS again. WPS should be updated ASAP to avoid this problem in 16.10. – user589808 Jan 14 '17 at 22:21
up vote 6 down vote accepted

The WPS Office for Linux up to version 10.1.0.5672~a21 ("Alpha21[2016-06-24]") - still depends on a deprecated library since Ubuntu 16.10, mentioned in the error message.

Workaround

Download and install the libpng12-0 version still available for Ubuntu 16.04 (xenial) before installing WPS Office for Linux.

  • up to version 10.1.0.5707_a21 – Samer Abu Gahgah Oct 19 '17 at 20:00
  • The new version has the same dependency to libpng12. -- The solution is also described here – Jaime Oct 20 '17 at 19:19

I was having same problem found solution:

Download libpng12-0 package from here

Install package using:

sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb 

Now install WPS office downloaded form here using:

sudo dpkg -i wps-office_10.1.0.5672~a21_amd64.deb 

I have tried this on Ubuntu 16.10 and it's working fine.

  • I have already downloaded the package. Its the same package i tried to install. – Alan Jameson Jan 14 '17 at 15:25
  • 1
    This is the standard procedure the user already tried. It has a dependency problem and this doesn't answer that problem. – user589808 Jan 14 '17 at 17:33
  • @CelticWarrior, I have edited the answer and now it solves dependency problem. – Rahul Jan 22 '17 at 3:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.