0

After installing ubuntu 16.04 on my HP I immediately found wifi problems: the wifi range was so weak that I had to stay next to the router, otherwise it notifies connection out of range. So I searched on the web and I found this guide: http://connectwww.com/how-to-solve-realtek-rtl8723be-weak-wifi-signal-problem-in-ubuntu/4625/

There I found the solution and my internet started working flawlessly. two days ago the problem came out again. I tried to follow the procedure descripted in the previous guide, since I read that you have to repeat this procedure after each kernel upgrade, but this time it didn't work.
this is the output of the command sudo lshw -c network, if you need it:

*-network
   description: Ethernet interface
   product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: enp2s0
   version: 07
   serial: 70:5a:0f:92:e2:9d
   size: 10Mbit/s
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:124 ioport:4000(size=256) memory:a1200000-a1200fff memory:a1000000-a1003fff
*-network
   description: Wireless interface
   product: RTL8723BE PCIe Wireless Network Adapter
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 00
   serial: 44:1c:a8:42:47:8f
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-59-generic firmware=N/A ip=192.168.1.5 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:17 ioport:3000(size=256) memory:a1100000-a1103fff

and this is the output of iwconfig:

wlp3s0 IEEE 802.11bgn ESSID:"Vodafone-26192315"
      Mode:Managed Frequency:2.442 GHz Access Point: 00:24:89:79:A8:78
      Bit Rate=72.2 Mb/s Tx-Power=20 dBm
      Retry short limit:7 RTS thr=2347 B Fragment thr:off
      Power Management:off
      Link Quality=44/70 Signal level=-66 dBm
      Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
      Tx excessive retries:0 Invalid misc:345 Missed beacon:0

enp2s0 no wireless extensions.

lo no wireless extensions.

output of grep [[:alnum:]] /sys/module/rtl8723be/parameters/*

/sys/module/rtl8723be/parameters/ant_sel:2
/sys/module/rtl8723be/parameters/debug:0
/sys/module/rtl8723be/parameters/disable_watchdog:N
/sys/module/rtl8723be/parameters/fwlps:N
/sys/module/rtl8723be/parameters/ips:N
/sys/module/rtl8723be/parameters/msi:N
/sys/module/rtl8723be/parameters/swenc:Y
/sys/module/rtl8723be/parameters/swlps:N
  • How did you set ant_sel=2? Did you also try =1? – chili555 Jan 14 '17 at 14:45
  • I tried that too but it didn't seem to work. So I uninstalled the drivers that I've early downloaded following the guide and I change the ant_sel option. So I solve the problem. You can read it here answers.launchpad.net/ubuntu/+question/439754 . Anyway thanks for the help – Marco Luzzara Jan 15 '17 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.