0

Right now I'm trying to install AMD Catalyst 14.6 drivers onto ubuntu 14.04. I made the driver executable and ran it, but i got this error

Please install the required pre-requisites before proceeding with AMD Catalyst installation. Please check file usr/share/ati/fglrx-install.log for more details.

I checked the log file and this is what it tells me.

NOTE: If your system has logged the missing packages required for installation, install them in the order as per the log file to resolve package-dependency issues.

fglrx installation requires that the system has kernel headers. /lib/modules/4.4.0-59-generic/build/include/linux/version.h cannot be found on this system.

Install kernel headers using the command apt-get install linux-headers-4.4.0-59-generic.

I tried to update the module but it says it is already in the newest version. I also went into my files and the /include/ directory wasn't there.

Can anyone tell me how to fix this? I'm a bit new to Linux but I'm up for any solution. I just need to install these graphics drivers so my video rendering isn't so choppy.

  • 1
    What was the result of the suggested fix? sudo apt-get install linux-headers-4.4.0-59-generic – chili555 Jan 13 '17 at 21:45
  • 1
    fglrx won't instll on 16.04 either way. – Pilot6 Jan 13 '17 at 21:55
  • More generally, you should install linux-generic-lts-xenial which depends on linux-headers-generic-lts-xenial which in turn depends on the most recent kernel header package for the 14.04.5 LTS kernel. – David Foerster Jan 13 '17 at 21:56
  • 1
    @Pilot6: It's 14.04 but the kernel is the same as in 16.04, so I guess the same applies. – David Foerster Jan 13 '17 at 21:57
  • Indeed. If you need fglrx, you'll need to switch back to the main 14.04 kernel and Xorg. – dobey Jan 13 '17 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.