3

If I'm browsing the internet and a page has both horizontal and vertical scroll bars it becomes really irritating to scroll with my touchpad. It keeps scrolling horizontally as well as vertically!

I'm using Ubuntu 16.04 and below are touchpad settings

Device 'SynPS/2 Synaptics TouchPad':
    Device Enabled (160):   1
    Coordinate Transformation Matrix (162): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (282): 1
    Device Accel Constant Deceleration (283):   2.500000
    Device Accel Adaptive Deceleration (284):   1.000000
    Device Accel Velocity Scaling (285):    12.500000
    Synaptics Edges (286):  1769, 5431, 1652, 4658
    Synaptics Finger (287): 25, 30, 0
    Synaptics Tap Time (288):   180
    Synaptics Tap Move (289):   242
    Synaptics Tap Durations (290):  180, 100, 100
    Synaptics ClickPad (291):   0
    Synaptics Middle Button Timeout (292):  75
    Synaptics Two-Finger Pressure (293):    282
    Synaptics Two-Finger Width (294):   7
    Synaptics Scrolling Distance (295): 200, 200
    Synaptics Edge Scrolling (296): 0, 0, 0
    Synaptics Two-Finger Scrolling (297):   1, 1
    Synaptics Move Speed (298): 1.000000, 1.750000, 0.036300, 0.000000
    Synaptics Off (299):    1
    Synaptics Locked Drags (300):   0
    Synaptics Locked Drags Timeout (301):   5000
    Synaptics Tap Action (302): 2, 0, 0, 0, 1, 3, 0
    Synaptics Click Action (303):   1, 1, 0
    Synaptics Circular Scrolling (304): 0
    Synaptics Circular Scrolling Distance (305):    0.100007
    Synaptics Circular Scrolling Trigger (306): 0
    Synaptics Circular Pad (307):   0
    Synaptics Palm Detection (308): 0
    Synaptics Palm Dimensions (309):    10, 200
    Synaptics Coasting Speed (310): 21.120001, 50.000000
    Synaptics Pressure Motion (311):    30, 160
    Synaptics Pressure Motion Factor (312): 1.000000, 1.000000
    Synaptics Resolution Detect (313):  1
    Synaptics Grab Event Device (314):  0
    Synaptics Gestures (315):   1
    Synaptics Capabilities (316):   1, 0, 1, 1, 1, 1, 1
    Synaptics Pad Resolution (317): 83, 46
    Synaptics Area (318):   0, 0, 0, 0
    Synaptics Noise Cancellation (319): 8, 8
    Device Product ID (277):    2, 7
    Device Node (278):  "/dev/input/event6"
  • How do you scroll? You can disable horizontal scrolling if you cant move fingers properly. – Pilot6 Jan 13 '17 at 19:32
  • wether I'm scrolling vertically or horizontally it scrolls both ways . – aeid Jan 13 '17 at 19:33
  • is there away s.t , I can only scroll at one axis at a time . – aeid Jan 13 '17 at 19:35
  • It is weird. That must be a bug. Try to install xserver-xorg-input-libinput. Reboot and test if it works the same way. – Pilot6 Jan 13 '17 at 19:38
  • after reboot it popped up an error ` no touchpad was found in the system ` – aeid Jan 13 '17 at 20:06
1

Recently libinput gained a feature to lock your scroll-movement either vertically or horizontally upon detecting that you're trying to scroll that way. The lock then gets unlocked if it detects deliberate diagonal movement, so you can e.g. move around in graphics editors, etc.

Here's a link to discussion. It's already been merged in git, and, if I correctly understand, will be part of libinput 1.12 release. So if you wanna try it, I encourage you to install libinput-1.12 (unreleased as of writing the answer) or later.

0

You can go to System -> Preferences -> Hardware -> Mouse, and there disable horizontal scrolling, also choose if you want edge scrolling or two-finger. You could maybe try to use one of the two with edge and the other with two-finger.

  • I don't wanna disable horizontal scrolling ! I wanna scroll in one direction at a time . – aeid Jan 13 '17 at 19:38
  • Isn't an option to use one with Edge-Scrolling (Horizontal, for example) and the other with two finger? – Yeib Beoulve Jan 13 '17 at 19:39
  • what do you mean ? – aeid Jan 13 '17 at 19:42
  • Well, at least in my touchpad config, I can choose wether I want to enable or not Horizontal and Vertial scrolling, and also if I want it to be a two-finger scrolling, or a edge-scrolling. Maybe you could use one of each, so it wont be made at the same time? – Yeib Beoulve Jan 13 '17 at 19:45
  • Look at this – Yeib Beoulve Jan 13 '17 at 19:47
0

The problem is related to some bug in xorg-synaptics. You can install and use a better user space driver for the same purpose, libinput.

It can be installed by

sudo apt install xserver-xorg-input-libinput

Tapping is disabled by default there, so you need to enable it if you like.

Run sudo -H gedit /usr/share/X11/xorg.conf.d/90-libinput.conf and add

Option "Tapping" "True"

to the touchpad section of the config file. Save the file and reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.