2

I was cleaning my keyboard with my computer suspended. When I turned on the monitor, my lock screen was totally different to what it should be like. I entered my password, and there was an error report for Ubuntu which I okayed. I hoped it was a one-off, but no!

Now when I lock my screen with super+L, my monitor turns off as though it is going into suspend, and when I move the mouse a black screen comes up before my desktop and the same strange lock screen. My computer suspends as you would expect, except that when I resume, I am faced with the strange lock screen.

I had a look to see if there was anything like it and came across a couple of examples. This seems to be the same problem, except when I login my lock screen is normal: What is this second login screen?. I tried the solutions suggested in that thread, but nothing works.

Same problem but I only have one monitor (no solutions to try in this thread): Lock screen is not working Ubuntu 16.04

When I lock the screen from terminal with dm-tool lock it is as expected, quickly going to the lock screen, and my traditional lock screen, until I enter my password, then instead of going straight to my desktop, it goes through the same thing as when I lock it with super+L -- the long suspense and monitor shutting off, followed by the strange lock screen (when I enter the password there I am returned to desktop).

This is the strange lock screen (with my username redacted)

Traditional lock screen:

Please can anyone suggest what I can do to rectify this?!

Also, I know I only have myself to blame, but surely typing any combination of characters in the password field on the lock screen shouldn't be able to change a fundamental thing like this?!

It sounds/looks like I might have pressed the combination ctrl+alt+* which has disabled a lock screen or something. I haven't enough posts to post another link. Google "Xorg 1.11 Vulnerability: Bypass Screen Lockers With A Keyboard Shortcut" and it is the first post that looks/sounds like what I might have done, but my Xorg server is 1.18, so I haven't tried anything suggested in the linked thread there as it is four years old!

9
  • You definitely didn't press something to bypass a lock screen. You just somehow changed your lock screen.
    – Kaz Wolfe
    Jan 13 '17 at 18:18
  • Ah, ok. I feel it is more than just the lock screen changed though, because of the different behaviour when using the keyboard shortcut, and then the two different lock screens when locking it through terminal.
    – ukubuntu
    Jan 13 '17 at 18:58
  • Ubuntu Error Tracker lists the program that crashed as 'compiz-core'. The contents of apport.log is as follows: ERROR: apport (pid 11153) Fri Jan 13 14:08:43 2017: called for pid 2103, signal 11, core limit 0 ERROR: apport (pid 11153) Fri Jan 13 14:08:43 2017: executable: /usr/bin/compiz (command line "compiz") ERROR: apport (pid 11153) Fri Jan 13 14:08:43 2017: debug: session gdbus call: (true,) ERROR: apport (pid 11153) Fri Jan 13 14:09:00 2017: wrote report /var/crash/_usr_bin_compiz.1000.crash
    – ukubuntu
    Jan 13 '17 at 19:06
  • Are there any other error logs or anything else I can do to help you diagnose the problem?
    – ukubuntu
    Jan 13 '17 at 19:12
  • I'm just curious... what happens if you do this, but select Unity as your lock screen?
    – Kaz Wolfe
    Jan 13 '17 at 19:14
3

This is the gnome-screensaver (at least I had the same problems few months ago).

sudo apt purge gnome-screensaver

should do the trick.

1
  • I ran that command and now i can't lock at all! The lock option is there but doesn't do anything Dec 4 '18 at 9:03
0
  1. If you have recently used lightdm-greeter this screen can appear to remove this perform following commands in terminal:

    sudo apt-get purge lightdm-gtk-greeter*
    sudo add-apt-repository --remove ppa:lightdm-gtk-greeter-team/stable
    sudo apt-get update
    
  2. Then edit the following file that reads the greeter:

    gksudo gedit /etc/lightdm/lightdm.conf.d/10-ubuntu.conf
    

    Change the line

    greeter-session=lightdm-gtk-greeter
    

    to

    greeter-session=unity-greeter
    

    If the line above does not exist, add it. If the above file/path does not exits (depends on Ubuntu version) try /etc/lightdm/lightdm.conf instead.

  3. Then reconfigure both DM and greeter

    sudo dpkg-reconfigure lightdm unity-greeter
    
  4. Then reboot.

0

I've had the same situation after my young daughter was playing with my laptop. :)

Try "alt+super+s" combination when you're on your desktop. Or go to: Universal Access > Screen Reader And turn it OFF. After that you should have normal default lock screen.

You had to press alt+super+s during cleaning, when screen was locked. It's also the way to reproduce this problem and to get this ugly lock screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.