1

After upgrading to 4.4.0-59 yesterday I realized today that my zfs partitions were gone! Googling a bit suggested that [http://pastebin.com/BPFj1Ewj ] zfs-native 0.6.5.7 did not like (as in: compile with) the -59 kernel.

Sure enough, zfs is missing from the -59 kernel (check last 2 lines):

% dkms status
bbswitch, 0.7, 4.4.0-53-generic, x86_64: installed
bbswitch, 0.7, 4.4.0-57-generic, x86_64: installed
bbswitch, 0.7, 4.4.0-59-generic, x86_64: installed
nvidia-340, 340.98, 4.4.0-53-generic, x86_64: installed
nvidia-340, 340.98, 4.4.0-57-generic, x86_64: installed
nvidia-340, 340.98, 4.4.0-59-generic, x86_64: installed
spl, 0.6.5.7, 4.4.0-53-generic, x86_64: installed
spl, 0.6.5.7, 4.4.0-57-generic, x86_64: installed
spl, 0.6.5.7, 4.4.0-59-generic, x86_64: installed
virtualbox, 4.3.36, 4.4.0-53-generic, x86_64: installed
virtualbox, 4.3.36, 4.4.0-57-generic, x86_64: installed
virtualbox, 4.3.36, 4.4.0-59-generic, x86_64: installed
zfs, 0.6.5.7, 4.4.0-53-generic, x86_64: installed
zfs, 0.6.5.7, 4.4.0-57-generic, x86_64: installed

Ok, what to do? Reboot under the previously known good kernel (-57)!

After rebooting, sure I can access my zpool, but my partitions are not mounted. To confuse matters even more,

zpool status
suggests I upgrade my pool:

% sudo zpool status
  pool: tank
 state: ONLINE
status: Some supported features are not enabled on the pool. The pool can
        still be used, but some features are unavailable.
action: Enable all features using 'zpool upgrade'. Once this is done,
        the pool may no longer be accessible by software that does not support
        the features. See zpool-features(5) for details.
  scan: none requested
config:

        NAME                                                STATE     READ WRITE CKSUM
        tank                                                ONLINE       0     0     0
          mirror-0                                          ONLINE       0     0     0
            ata-ST4000DM000-1F2168_S3014GKE-part4           ONLINE       0     0     0
            ata-WDC_WD40PURX-64GVNY0_WD-WCC4E5UZUFFD-part4  ONLINE       0     0     0

errors: No known data errors

Dare I do that? Or, did something get messed up during the failed update to 4.4.0-59? I have installed zfs via

apt-get install ubuntu-zfs
and do not feel brave enough to try to compile and install the zfs module myself. For now, I just want my zfs partitions back!

Update: I have posted the solution that worked below. It might be against askubuntu rules, but I wanted to have this info out as soon as possible if someone else were to run into the same problem.

  • Is secure boot disabled in the BIOS? Do a modinfo and check the vermagic value in the zfs kernel module and make sure it matches the new kernel version. – heynnema Jan 13 '17 at 17:49
  • 1
    The upgrademessage is due to a new version of ZFS you are using (newer than the one your pool was created with). There is no need to update the pool, as long as you do not need the new features (and if you don't know what they are, you do not need them!). If you upgrade your pool, you will have problems in case of downgrading the ZFS version (aka "Fetaure Flags", see e.g. open-zfs.org/wiki/Feature_Flags) – ridgy Jan 13 '17 at 18:16
  • @heynnema: Yes, secure boot was disabled. How would that affect zfs? And re modinfo, how could I do that when the zfs kernel module failed to load (compile?) with the -59 kernel? – Niclas Börlin Jan 14 '17 at 13:44
  • 1
    @NiclasBörlin Ubuntu will no longer load unsigned kernel modules with secure boot enabled. You would know because none of your other dkms modules would load either. In looking closer at your dkms status I see that zfs doesn't appear for the -59 kernel. More importantly it doesn't even appear as ADDED or BUILT. Try building zfs outside of dkms by cd /usr/src/zfs-0.6.5.7 and do a make and see if it compiles correctly. Do a make clean when you're done to clean up. If it does compile, you'll need to use dkms add/build/install commands to install it via dkms. – heynnema Jan 14 '17 at 15:28
  • @heynnema Thank you for your input. I have clarified that I installed zfs through the ubuntu-zfs package and not built the kernel module myself - I don't feel competent enough. If I feel brave at some later date I will consider your comments. :) – Niclas Börlin Jan 14 '17 at 16:14
1

The answer that worked was to uninstall the -59 kernel:

% dpkg --get-selections | grep 4.4.0-59
linux-headers-4.4.0-59                          install
linux-headers-4.4.0-59-generic                  install
linux-image-4.4.0-59-generic                    install
linux-image-extra-4.4.0-59-generic              install
linux-signed-image-4.4.0-59-generic             install
% sudo apt-get remove --purge linux-headers-4.4.0-59 linux-headers-4.4.0-59-generic linux-image-4.4.0-59-generic linux-image-extra-4.4.0-59-generic linux-signed-image-4.4.0-59-generic

After rebooting, now everyting is back to normal! The upgrade message is still there, but my zfs pool works! A better solution would obviously be to have zfs work with -59 (and later) kernels, but for now I am happy.

0

After a few days an update to zfs-0.6.5.8 appeared. After installing it, re-installing the -59 kernel produced no error messages. However, my partitions were not mounted automatically at boot. A modification to

ZFS_AUTOIMPORT_TIMEOUT='45'
(from 30) in
/etc/defaults/zfs
solved that. So now everything appears to be back to normal!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.