0

This question already has an answer here:

Note: I have already checked all the answers available on stackoverflow and various other forums. But could find no solution that would help me solve "grub install /dev/sda failed fatal error"

I have made sure the UEFI mode is selected and not legacy. Secure boot is off. Fastboot is turned off.

There is one partition(sda 6 for ubuntu). sda 1 EFI for as windows boot manager(And assuming that grub will be installed here). I am using live usb to install Ubuntu.

I have also tried with and without a new EFI drive sda4. Please help me resolve this and get Ubuntu 16.04 installed

I have attached the screenshots for reference.

UEFI Boot selected

partition list

marked as duplicate by David Foerster, Eric Carvalho, Eliah Kagan, Pilot6, Kaz Wolfe Jan 26 '17 at 17:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you notice a warning message about installing in UEFI mode during the process? If so what did you do? – user589808 Jan 13 '17 at 17:12
  • There's something weird about your sda though. The first "EFI System" partition looks right, 500MB. There should be only one per drive and yet your show a second 4.7GB "EFI System" partition?? – user589808 Jan 13 '17 at 17:16
  • @CelticWarrior I added the second one assuming that would somehow install the grub in the secind EFI. I am sure it is wrong. But I assure you I did not work and showed the same error even before the new partition was made – Mukund Gandlur Jan 13 '17 at 17:24
  • Yes, unrelated but you should remove that monstrosity anyway (use the space to create perhaps a NTFS shared data partition accessible from both Ubuntu and Windows). – user589808 Jan 13 '17 at 17:27
  • Sure... Any other ideas? – Mukund Gandlur Jan 13 '17 at 17:27
-1

I experienced the same problem while trying to install Ubuntu 14.04 alongside Windows 8.1 Pro. However, make sure you uncheck Turn off secure boot, and then reboot your computer. After that press F8 or F2 depending on your computer, then make sure you boot in UEFI and not Legacy.

After installing Ubuntu, reboot the system. If it chooses Ubuntu automatically and didn't show the GRUB boot loader, this means you have to do one more step.

In Ubuntu, after logging in:

  • Connect to the Internet.
  • Open a new Terminal by pressing Ctrl+Alt+T, then type the following commands (press Enter after each line):

    sudo add-apt-repository ppa:yannubuntu/boot-repair
    sudo apt-get update
    sudo apt-get install -y boot-repair && boot-repair
    

This boot manager will help uninstalling the old version of GRUB and reinstalling a new version of it. Just follow its steps.

I hope I solved your problem. If there's anything else, please leave a comment.

  • I will try this and let you know if it works – Mukund Gandlur Jan 13 '17 at 17:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.