0

I'm trying to install OpenOffice on Ubuntu 16.04 64 bit.

  1. I uninstalled LibreOffice per the command line

    sudo apt-get remove --purge libreoffice-core
    
  2. I originally downloaded the Apache_OpenOffice_4.1.3_Linux_x86-64_install-deb_en-US.tar.gz, unzipped it on the Desktop and manually went through, double clicking on every *.deb package and letting the software center install it. This did not work. There was no item in the menu for OpenOffice and there was nothing when I did a search.

  3. I then tried to install the DEBs from the command line:

    cd en-US/
    cd DEBS/
    sudo dpkg -i *.deb
    

    This did not work either

  4. I then tried another removal of LibreOffice just to be sure:

    sudo apt-get purge libreoffice
    

    And still there was nothing in the menu even when searching. A command line command of "soffice" only yielded:

    /usr/bin/soffice: 175: exec: /usr/lib/libreoffice/program/oosplash: not found
    
  5. I then tried:

    sudo add-apt-repository ppa:upubuntu-com/office
    sudo apt-get update
    sudo apt-get install openoffice
    sudo apt-get install libxrandr2:i386 libxinerama1:i386
    sudo chmod a+rx /opt/openoffice4/share/uno_packages/cache
    

    Still received the same results as before.

  6. I then tried the following:

    cd desktop-integration/
    sudo dpkg -i *.deb
    

    Still, same results as above.

  7. I then downloaded the newest JRE 64 bit and unpacked/installed in the /usr/java directory.

    sudo tar zxvf jre-8u111-linux-x64.tar.gz
    

    And I still don't have a working OpenOffice.

Is this a wild goose chase? Does OpenOffice simply not work on Ubuntu 16.04?

0
1

Try to use the GDebi package manager to install *.deb packages. Install it by running:

sudo apt-get install gdebi

Then, to install a package, right click your *.deb package → Open withGDebi Package InstallerInstall package.

I like this because you can see detailed dependencies that you needed in status.

2
  • Thanks for the tip. I tried to install the main *.deb for OpenOffice through gdebi and it said it was already installed, but I clicked on the reinstallation option. Nothing wrong. Successfully installed. So then I tried to install the menus *.deb through gdebi. This time it came up with an error "dpkg: error processing archive /.../openoffice4.1-debian-menus_4.1.3-9783_all.deb (--install): trying to overwrite '/usr/bin/soffice', which is also in package libreoffice-common 1:5.1.4-0ubuntu1"...................... Jan 13 '17 at 20:32
  • 1
    So I ran "sudo apt-get purge libreoffice-common" and then re-ran the installation for the menus *.deb and all seems well. Thanks again for the tip and the help. Maybe help articles/postings should start including the purging of libreoffice-common from now on as well. Jan 13 '17 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.