I can't play any 3d games on Ubuntu 11.10 64 bit because of texture gliches, desktop looks ok but games terrible with Intel HD 3000. Any solution for this? The laptop is HP 4530s. exaple Minecraft problem (but it exist in every game) http://img51.imageshack.us/img51/2629/minecraftproblem.png


This bug is your issue. Buggy intel drivers. There are some very ugly workarounds that I have tried myself that can make the artifacts go away but (in the case of minecraft, at least) do not help the screen flickering.

EDIT: Here's the workaround I crafted up. Firstly, you'll need a newer version of intel-gpu-tools to tweak some data. Go here to pick up a newer version. You may add the PPA but to avoid a lot of unnecessary updates I recommend just manually downloading the package through "View Package Details", then expand the dropdown entry for the oneiric series and download either the AMD64 or i386 package, depending on whether you have 32 or 64 bit. Install the package.

With this installed, you're going to make a crontab. This will run a command AS ROOT on boot. Run the command:

sudo crontab -e

in the terminal. Type in your password. It will ask you which editor to use. Just pick the default (nano). Scroll down to the bottom and on a new line enter the following:

@reboot intel_reg_write 0x9404 0x00001800

To save and exit, press control+x, type y, then press enter. Perform a reboot.

From now on the artifacts should no longer be there.

| improve this answer | |
  • It would be great. btw. does anybody know if other distros don't have that issue? And will it be fixed in precise (12.04)? – Andy Dec 12 '11 at 15:11
  • I'm very confident that it will be fixed. I believe I looked at the upstream reports and the issue seems to be well-known and actively worked on. I think the issue is with all distros as even the latest xorg versions had the issue and people have been actively building newer versions. Any older versions probably just won't work since it's new hardware. (I haven't tried any others out, it's actually not my machine this affected). Sorry about that, it really sucks to be in this position :/. I'll write up my workaround. – user6658 Dec 12 '11 at 16:06
  • I added my workaround. Be advised that if this doesn't work or isn't good enough for you I would suggest removing the @reboot line from that file. Also, you should make a calendar note of some sort for when you upgrade that machine to 12.04 to remove that line. While it may work fine now there's no telling what keeping an arbitrary command execute like that will do to a future version. – user6658 Dec 12 '11 at 16:22
  • Thank you! As you said that fixed artifacts but to 100% happiness I had to install optimized driver (phoronix.com/forums/…). – Andy Dec 12 '11 at 17:33
  • Wait, so did following that article completely remove the issues? It says it supports 10.10 and 11.04, not 11.10. Does it work regardless? – user6658 Dec 12 '11 at 17:43

Iam currently using Ubuntu 12.04 and had the same problem. Here is what i do:

Install mesa 3d graphic library(I think this was the command, correct me if not)

sudo apt-get install libgl1-mesa-glx

Then install this library that lets mesa use texture compression

sudo apt-get install libtxc-dxtn-s2tc0

No extra ppa needed. I test it with Amnesia an Minecraft and both work perfectly.

| improve this answer | |
  • Both packages were already installed in Ubuntu 12.10 and I still have flickering when playing Amnesia. – Serrano Jan 16 '13 at 0:29

Are you sure is that bug? I believe that you have this issue:

The problem is that when you remove the Nvidia drivers, the files in /usr/lib/xorg/modules/ are removed. But if you reinstall the intel driver it will copy the files back again and everything will be fine! Run these commands in the Terminal:

sudo apt-get remove xserver-xorg-video-intel
sudo apt-get install xserver-xorg-video-intel

Check it out here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.