5

I just installed and updated a Ubuntu Xenial with Unity on Dell Vostro 14 3446 laptop. Earlier, I have used Ubuntu Trusty and Linux Mint 17 and 18 on this same laptop and the touchpad has never given any problems. Now, it has both vertical and horizontal scrolling enabled by default and I can't find a way to disable the horizontal scrolling.

$ xinput -list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ DLL0662:00 06CB:2985                      id=12   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=15   [slave  keyboard (3)]

This is what I have tried yet:

  1. Removed xserver-xorg-input-synaptics and xserver-xorg-input-evdev, installed xserver-xorg-input-libinput and restarted. This resulted in Tap-to-Click getting disabled and the Touchpad settings disappearing. libinput was uninstalled after this and synaptic driver reinstalled.

  2. Executed synclient HorizTwoFingerScroll=0. After doing this, synclient | grep -i horiz prints this:

    HorizScrollDelta = 110 HorizEdgeScroll = 0 HorizTwoFingerScroll = 0 HorizHysteresis = 27

And yet, horizontal scrolling is still on.

Is there any way to disable this? Linux Mint 18 Cinnamon gave an option to disable it, so it's definitely possible. But how?

  • You need to uninstall libinput to get xorg-synaptics settings to work. – Pilot6 Jan 13 '17 at 14:26
  • I did that. Adding to question – strNOcat Jan 13 '17 at 14:26
  • Anyway libinput works better. You do not have GUI settings, but you do not need them every day. – Pilot6 Jan 13 '17 at 14:28
6

It is quite easy to do if you installed libinput.

Edit /usr/share/X11/xorg.conf.d/xx-libinput.conf ( replace the xx with the right number for your system; often 90 or 40 ) and add

Option "HorizontalScrolling" "False"

to the touchpad section.

xorg-synapics and libinput have different config files.

Option "Tapping" "True"

will enable tap-to-click function. It is disabled by default.

You can see the full list of options HERE

  • But libinput basically broke my touchpad with Tap-to-Click not working and Touchpad settings disappearing (meaning no way to enable it back) – strNOcat Jan 13 '17 at 14:09
  • You can enable tap-to click by Option "Tapping" "True" – Pilot6 Jan 13 '17 at 14:11
  • why can't I find 90-libinput.conf ? – aeid Apr 20 '17 at 11:12
  • @aeid I have no idea why you can't find it. If you have another question, you can always ask it with some details regarding your situation. – Pilot6 Apr 20 '17 at 11:14
  • 3
    Worked in Ubuntu 17.10 running on X11, libinput is the default library (no installation needed). I had edited 40-libinput.conf. – leoperbo Jan 13 '18 at 23:21
1

An easier way (from https://askubuntu.com/a/338312/48493), that worked for me on Ubuntu 17.04. This is for on-the-fly changes to setttings, however:

synclient HorizTwoFingerScroll=0
  • note that this answer is for xorg-synaptics, not libinput. – NotSimon Mar 15 '18 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.