0

mongod process restarting frequently with this:

E STORAGE  [thread2] WiredTiger (13) [1484274727:920198][12108:0x7f9e77225700], file:WiredTiger.wt, WT_SESSION.checkpoint: /data/mongodb/data/WiredTiger.turtle: file-exist: stat: Permission denied
E STORAGE  [thread2] WiredTiger (13) [1484274727:920463][12108:0x7f9e77225700], checkpoint-server: checkpoint server error: Permission denied
 E STORAGE  [thread2] WiredTiger (-31804) [1484274727:920485][12108:0x7f9e77225700], checkpoint-server: the process must exit and restart: WT_PANIC: WiredTiger library panic
        [thread2] Fatal Assertion 28558
        [thread2]
        [WTJournalFlusher] Fatal Assertion 28559
        [WTJournalFlusher]
        [thread2] Got signal: 6 (Aborted).

Permissions of file:

 /data/mongodb/data# ll WiredTiger.turtle
-rw-r--r-- 1 mongodb nogroup 945 Jan 13 05:56 WiredTiger.turtle

Current version is 3.2.9. This is upgraded version from 2.X . We are managing mongodb service through chef.

Do I need to start service with service mongodb or service mongod? I see that service is starting by user mongodb and group nogroup.

/data/mongodb/data# ll /proc/8241
total 0
dr-xr-xr-x   9 mongodb nogroup 0 Jan 13 02:34 ./
dr-xr-xr-x 111 root    root    0 Sep  1 04:38 ../
dr-xr-xr-x   2 mongodb nogroup 0 Jan 13 04:07 attr/
-rw-r--r--   1 mongodb nogroup 0 Jan 13 04:07 autogroup
-r--------   1 mongodb nogroup 0 Jan 13 02:34 auxv
-r--r--r--   1 mongodb nogroup 0 Jan 13 04:07 cgroup
--w-------   1 mongodb nogroup 0 Jan 13 04:07 clear_refs
-r--r--r--   1 mongodb nogroup 0 Jan 13 02:37 cmdline
-rw-r--r--   1 mongodb nogroup 0 Jan 13 04:07 comm
-rw-r--r--   1 mongodb nogroup 0 Jan 13 04:07 coredump_filter
-r--r--r--   1 mongodb nogroup 0 Jan 13 04:07 cpuset
lrwxrwxrwx   1 mongodb nogroup 0 Jan 13 04:07 cwd -> //
-r--------   1 mongodb nogroup 0 Jan 13 04:07 environ
0

Use sudo service mongodb start to start the service. It will start the MongoDB service from the relevant user. It won't occur any errors once you do that.

| improve this answer | |
  • 1
    I have started the service using service mongod start and modified init file to start with group "mongodb" .. Issue is resolved now.. Thanks for your response. – Vasu Tubati Feb 1 '17 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.