2

I have searched all the posts here on ask ubuntu on how to do this and can't seem to figure it out still. What is the best way to disable and enable turbo boost? My fans are running quite loud on my x220 so I'd like to disable it. Thanks!

  • It depends on which CPU frequency scaling driver you are using. cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver – Doug Smythies Jan 13 '17 at 4:45
  • If intel_pstate, then see here. – Doug Smythies Jan 13 '17 at 4:49
  • @DougSmythies - What that says is: use cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver to see if intel_pstate. In my case yes. Then, cat /sys/devices/system/cpu/intel_pstate/no_turbo to see the status of turbo boost (0 means off, 1 means on). Mine is on. But then, to disable it should be echo "1" | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo, but what I get is 1 tee: /sys/devices/system/cpu/intel_pstate/no_turbo: Operation not permitted. sudo before that as indicated in comment gives the same. – user47206 Jan 27 '17 at 14:04
  • 1
    @cipricus : No, 1 means turbo disabled and 0 means turbo enabled. In your case it is disabled in the BIOS and therefore you can not change it. see also (your question) here. – Doug Smythies Jan 28 '17 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.