1

I have a Lenovo Y50-70 with Ubuntu 16.04 and Bluetooth problems.

Previously I had elementary OS installed and the Bluetooth worked fine.

It currently detects the Bluetooth adapter but does not allow me to change visibility of the system to be discoverable nor find any devices.

I tried running a live USB with Ubuntu and the Bluetooth worked just fine, it allowed me to change settings and discover devices, which makes me think there is something broken on my installation.

How can I reset the settings or fix this issue?

I'm hoping I can avoid a clean install.

This is the output of lspci -knn | grep Net -A2; lsusb:

08:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
Subsystem: Lenovo RTL8723BE PCIe Wireless Network Adapter [17aa:b736]
Kernel driver in use: rtl8723be
Kernel modules: rtl8723be
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 045e:07b2 Microsoft Corp. 
Bus 003 Device 003: ID 0bda:b728 Realtek Semiconductor Corp. 
Bus 003 Device 002: ID 174f:14b8 Syntek 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A2; lsusb terminal command. – Pilot6 Jan 12 '17 at 16:11
  • @Pilot6 added the output of lspci -knn | grep Net -A2; lsusb – Jorge Cuevas Jan 12 '17 at 16:15
  • rtl8723be is a combo chip, Wi-Fi+BT. WiFi is fixable, but BT is problematic. – Pilot6 Jan 12 '17 at 17:04
2

That's a problematic chipset. In Ubuntu 14.04 the BT device was not supported on Linux, but it was possible to install a custom rtl8723au-bt module. I even added to my PPA as a DKMS module. It used to work quite well.

Now the code has been merged into the Linux tree, and the device is supposed to be supported. But many people complain that it actually does not work well enough.

The old DKMS module does not work on new kernels.

I do not have this hardware, that's why I do not have a chance to investigate this problem and suggest a solution.

I can suggest to search the net by "linux rtl8723be bluetooth". Maybe someone has fixed it some way or another. Also I would recommend to create a bug report at Launchpad if it does not exist.

It may also be useful to contact the kernel maintainers, but this require some background.

This is not a solution of your problem, but it is an answer containing all my knowledge on this topic.

Update Now this problem seems to be fixed in current Ubuntu kernels. Realtek bluetooth should work out of the box.

  • I found a GitHub repository github.com/lwfinger/rtlwifi_new, it is supposed to have all the new realtek drivers, are there any precautions I should take before trying to install them? – Jorge Cuevas Jan 12 '17 at 16:56
  • That won't work. rtlwifi-new are only wireless drivers. There is rtl8723au-bt repo there (lwfinger). That's what I told about. But it does not work with new kernels. But you can try to contact Larry Finger, maybe he has some good news. – Pilot6 Jan 12 '17 at 17:00
  • If it is useful to anyone else, I ended up installing ubuntu 16.04 over my broken system and Bluetooth is working fine now I guess it had something to do with me installing blueman on the broken system. – Jorge Cuevas Jan 13 '17 at 0:09
  • 1
    @Pilot6 Sorry for arguing and downvote You have right i have different chipset in my Lenovo i've deleted bad comment. My mistake :-( Have a nice day! – BaronBaleron Feb 19 '19 at 18:46
  • No problem. This happens. You have a correct solution for your chipset.You can revert the downvote though. – Pilot6 Feb 19 '19 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.