There have been numerous posts on external monitor support for the Dell XPS 13" laptop but unfortunately they haven't been of much help. I have a USB 3.0 dongle from Dell called DA100 that offers extensions to HDMI and VGA outputs among others. It employs a DisplayLink chipset which is supported by Ubuntu (http://www.displaylink.com/downloads/ubuntu). I'm using Kubuntu 16.04 with

jimakos@kubu:~$ uname -a
Linux kubu 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

My laptop screen is set to 3200x1800 and my external monitor is a 1920x1080. I've setup correctly my dpi as well following the links in

https://askubuntu.com/questions/19782.../272172#272172. For example

jimakos@kubu:~$ xdpyinfo |grep dots
resolution: 277x277 dots per inch 

which is the correct dpi for my resolution.

xrandr identifies both monitors correctly

jimakos@kubu:~$ xrandr | grep -w connected
eDP1 connected primary 3200x1800+0+0 (normal left inverted right x axis y axis) 294mm x 165mm
DVI-I-1-1 connected 1920x1080+3200+0 510mm x 287mm 

and I can enable the external one in System Settings -> Display and Monitor.

At this point my external monitor is activated with a black desktop and the desktop toolbox appears at the top left corner. I suppose they are in a side-by-side configuration. The problem is that everything appears huge on the external monitor, obviously because I use a scale factor of 2 for my highDPI laptop screen to get a nice output. Ideally, the solution would be to set 2 different scalings for the laptop and the external monitor, right?

I tried some xrandr commands shown here https://askubuntu.com/questions/39340...fferent-screen and here https://wiki.archlinux.org/index.php...tiple_displays but I was not able to scale down the external monitor. For example I tried to run (DVI-I-1-1 is my external monitor)

jimakos@kubu:~$ xrandr --output DVI-I-1-1 --scale 2x2
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 26 (RRSetCrtcTransform)
Value in failed request: 0x129
Serial number of failed request: 48
Current serial number in output stream: 49

Next I tried to downscale the fonts dpi via System Settings -> Fonts to just 96 and rebooted. Most of the desktop components were shrunk and appeared fine on my external monitor. However, application like Kate, Texstudio, or even the environment for the Settings were still scaled up and only the fonts were small. Firefox, Chrome or Thunderbird appear just fine. Mouse is a bit sluggish by the way. This is the closest I've got to a solution.

Do you think that a direct cable for the USB-C video output of XPS would work better or is it irrelevant to the scaling problem?

ps: in Windows 10 I was able to get a working setup on the very same monitor.

  • I have the same problem and try a lot of things but nothing works. I had hope that the new 17.04 version that has improvements in the HD screens support will fix this issue but nope :( – Aracem Apr 24 '17 at 10:43
  • I switched to Ubuntu 16.04 and everything works like a charm. In the Monitor settings you can simply drag a slider to configure scaling for menus and titles. Everything scales perfectly - there can be of course apps that don't natively support HighDPI but this is not an issue of OS. – Jimakos Apr 27 '17 at 10:21
  • it worked well to me with xrandr --output DP-1 --scale 2x2 – lorussian May 16 at 19:56

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.