1

wireless-info here

I've noticed the following problems in my wi-fi:

  1. Wi-fi is sometimes slow or doesn't connect to the usual spot after waking from suspend mode.
  2. Internet speed only reaches 2mbps (compared to the dual-booted Windows installation which reaches 10mbps)
  3. Wi-fi is very slow sometimes, even timing out some pages.

This only happens in the Ubuntu installation, as the wifi connection to my phone and when tried on Windows are working fine.

I'm fairly new to Ubuntu so appreciate any guidance and steps I can do to resolve this. Thanks!

(I've viewed some similar posts about this, it didn't help solve my issue at all)

UPDATE: I tried sitting beside the router then doing speedtest -- the speed bumped up considerably (almost near the speeds I achieve in Win10) -- any possible cause?

  • At your router, change the wireless encryption settings to WPA2-AES only, not any WPA/WPA2 mixed mode (your current setting) and certainly not TKIP (also your current setting). This will improve connection to all. The current devices that work acceptably with your current settings will work the same or better. – user589808 Jan 11 '17 at 21:20
  • The above notwithstanding, you may have other issues with that Atheros driver but you need to do the aforementioned changes before any further troubleshooting. – user589808 Jan 11 '17 at 21:21
  • Thanks @CelticWarrior for the suggestion. Unfortunately my internet provider has locked up access to the router. Would you have any other troubleshooting suggestions? Worst case, I'll have to call them to change this setting. – Karl Jamoralin Jan 11 '17 at 21:39
  • This settings should be enough but if not their the starting point. – user589808 Jan 11 '17 at 21:41
  • Ok thanks! Will do this and update the thread as soon as there's progress. – Karl Jamoralin Jan 11 '17 at 21:42
1

I would disable the power management for wifi with this in terminal

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Reboot

I would agree with CelticWarrior about disabling TKIP if disabling the power management doesn't completely fix the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.