0

I installed UbuntuStudio in a VirtualBox machine and everything works fine except for the sound.

When I go for example to this website and I play a note (with the mouse), the key changes it's state to pressed instantly, but I can only hear the sound a few noticeable milliseconds later which is quite annoying.

I think that the problem may be one of two things:

  1. The fact that I am running UbuntuStudio in VirtualBox

  2. The sound driver

Well, I could try to install UbuntuStudio in the computer itself instead of a virtual machine, but I don't want that, I want to use it in VirtualBox.

In terms of the sound driver, I tried everything but nothing seems to work.

I don't think that the problem is lack of hardware performance because I have a fairly good computer.

Specs of my computer:

NVIDIA GeForce GTX 950M

Intel Core i7 6700HQ

8Gb DDR4 RAM

And I made available to my virtual machine 4Gb of RAM memory.

Can anyone help me with this problem? Or at least guide me to some path...

15
  • In what operating system is the VM running? – Jacajack Jan 11 '17 at 15:02
  • It's Windows 10 x64. – user2699664 Jan 11 '17 at 15:04
  • Have you considered the option that it may be problem with sound latency in Windows, not the Ubuntu Studio? Have you tried "faster" drivers like ASIO? (I'm not sure if VirtualBox can handle them, though) – Jacajack Jan 11 '17 at 15:08
  • I don't think that the problem is in Windows because I testes the website that I mencioned in Windows and it worked just fine. I also tried to change the audio controller in VirtualBox settings but it didn't work. How can I test that ASIO driver? Do I have to install it in Windows or Ubuntu? – user2699664 Jan 11 '17 at 15:12
  • Oh, sorry I misread your question a little bit. The (ASIO driver)[asio4all.com] is meant for Windows. I remember using it back in the times when I had windows, because I was experiencing delay in different music software (for example M1Le). I haven't seen anything like this in my Ubuntu so far, so that's why I supposed Windows may be the issue here. – Jacajack Jan 11 '17 at 15:18
2

Terribly sorry, but it's this specific issue with virtual machines and the high amount of processing that's needed that makes Ubuntu Studio unsupported on virtual machines. There is no way to make a virtual machine's audio latency any lower than what you are experiencing in this use case.

Source: I lead Ubuntu Studio currently.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.