Ubuntu's Terminal uses case-sensitive auto-completion, as would be expected for Linux.

But I think sometimes it would be more convenient to use a case-insensitive one instead, to save you having to be accurate while starting a name, and would probably be worth the extra false positives. Is it possible to change this behaviour?

  • Very good question. As a usability tool, tab-completion should not be as strict as the computer system in general when it comes to naming things.
    – masterxilo
    Jan 23, 2019 at 8:55

4 Answers 4


In order to make bash case-insensitive for to current user:

Run the following shell script in a terminal:

# If ~/.inputrc doesn't exist yet: First include the original /etc/inputrc
# so it won't get overriden
if [ ! -a ~/.inputrc ]; then echo '$include /etc/inputrc' > ~/.inputrc; fi

# Add shell-option to ~/.inputrc to enable case-insensitive tab completion
echo 'set completion-ignore-case On' >> ~/.inputrc

Start a new shell (reopen the terminal).

To Make the changes systemwide:

# add option to /etc/inputrc to enable case-insensitive tab completion for all users
echo 'set completion-ignore-case On' >> /etc/inputrc
# you may have to use this instead if you are not a superuser:
echo 'set completion-ignore-case On' | sudo tee -a /etc/inputrc

For details, see man bash . Yes it is a long page, but bash is a somewhat complex program, and if you want just search that page for "case-insensitive" to go to the relevant section. People usually learn bash one option at a time or one bash script at a time and it takes a long time to master all the nuances. Your interest may vary.

  • Thanks. I appreciate the user-specific/non-admin friendly solution. The echo line seems to have worked, but now I seem to have lost the ability to use Ctrl-Left/Right to move the cursor. Also, would >> be safer than >?
    – mwfearnley
    Dec 12, 2011 at 6:27
  • In general >> is going to be safer, my mistake, I was assuming you did not have a ~/.inputrc . I also set noclobber =) Bit sure why your arrow keys are not working, I can not replicate that. You can remove ~/.inputrc and start a new shell.
    – Panther
    Dec 12, 2011 at 6:30
  • Yeah, it works again if I remove it.. According to linuxfromscratch.org/blfs/view/5.1/postlfs/inputrc.html the new inputrc might be overriding the global one?
    – mwfearnley
    Dec 12, 2011 at 7:00
  • 4
    Holy shit, I copied this into /etc/inputrc and I can't type "i" anymore and when I type "e" it just spams "ssssssssss[..]" into the console.. better use the solution from @emtin4
    – Luca Steeb
    Mar 31, 2016 at 23:49
  • 4
    @LucaSteeb I hit that too, but then realized this whole block is not supposed to be put in your .inputrc, but typed once. Only $include /etc/inputrc and set completion-ignore-case on should be in your ~..inputrc file.
    – Chris
    Jan 8, 2018 at 19:32

Open a terminal and type the below command:

echo set completion-ignore-case on | sudo tee -a /etc/inputrc

Enter password. Restart terminal.

If in some case you want to remove case insensitive, just edit /etc/inputrc file by removing the set completion-ignore-case line.

That's all.

  • OK, I clarified that for you. It takes a while to learn about bash, but keep exploring, reading, and asking. linuxcommand.org is a popular start ;)
    – Panther
    Dec 14, 2011 at 16:46
  • 4
    In case there is more than one user, this changes it for all, which may or may not be the desired behavior Jun 19, 2015 at 17:35
  • 3
    by far the most straight forward and simplistic answer here
    – workabyte
    Jun 30, 2016 at 21:31
  • simple and clear answer Sep 2, 2018 at 7:29

I know this question is very old but unless I am missing something I think I have a super simple solution if you are using bash.

echo "bind 'set completion-ignore-case on'" >> ~/.bashrc

Or just add the line using your favorite text editor. Restart your bash session and enjoy.

  • 4
    Well, you're missing something: ~/.inputrc is read by readline, which is what bash uses to provide this completion. Readline is also used by other programs, so, for generally setting this, ~/.inputrc as suggested the accepted answer would be better.
    – muru
    Jan 31, 2016 at 2:50
  • Thanks for your suggestion, it teaches me a little more, but I have to say that it doesn't seem any simpler than the one I accepted, which just uses an additional line to ensure the new file doesn't nullify the old.
    – mwfearnley
    Feb 1, 2016 at 20:52
  • perfect. well the only thing to remember is bind 'set completion-ignore-case on' should go in new line of .bashrc
    – Vishrant
    Aug 18, 2018 at 23:20
  • thanks! using bind will be more easier to execute in a public system instead of modify any other files (~/.inputrc).
    – Marslo
    Nov 17, 2020 at 13:59
  • +1. This is the only one that works on git bash in Windows (where bind is necessary)
    – JBSnorro
    Sep 4, 2022 at 9:09

You can do this by setting a configuration variable for GNU readline, which is what handles the input in an interactive shell.

The variable needed is completion-ignore-case, and can be set directly in your bash session with:

bind "set completion-ignore-case on"

It can be enabled for all future bash sessions by putting set completion-ignore-case on into the users's ~/.inputrc file, or the system /etc/inputrc, to enable it for all users. This is the initialisation file for readline.

Note that ~/.inputrc probably doesn't exist, and if you create it, your local version will override the system version at /etc/inputrc. The system version has lots of useful key mappings configured, such as Ctrl-Left/Right, and you have to link in the system version so you don't lose them.

The way to do this is to put the line $include /etc/inputrc at the top of ~/.inputrc, e.g.:

$include /etc/inputrc

set completion-ignore-case on

Once configured, you can apply the change, either by restarting bash, or reload inputrc, e.g. with Ctrlx,Ctrlr.)

More information about readline and inputrc can be found in man bash and man 3 readline.

  • When I run man bind in bash, I see the description for bind(2) to be "bind a name to a socket". Is that the same bind as you are using? Is there another bind? May 26, 2023 at 17:16
  • 1
    @PeterBergman type bind shows it's a bash builtin, so it doesn't get its own manpage - though sometimes there may be one for a non-builtin with similar functionality. There's some info with help bind, or you can search man bash for ` bind `.
    – mwfearnley
    May 27, 2023 at 6:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .