I am trying to install the linux-image-extra-* packages, (which are a prerequisite for Docker) following the instructions here.

sudo apt-get install linux-image-extra-$(uname -r) linux-image-extra-virtual

But i get the following error message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
linux-image-extra-3.19.0-32-generic is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-image-extra-virtual : Depends: linux-image-generic (= but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried fixing any broken dependencies using the following command:

sudo apt-get -f install

Which gives me the following output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 to upgrade, 0 to newly install, 0 to remove and 152 not to upgrade.

And then ran the command to install the linux-image-extra-* kernel packages, but i still get the same error.

I tried sudo apt-get update followed by the command to install the linux-image-extra-* kernel packages, but the same thing still.

What could the issue be? And how do i resolve it?

My system:

Ubuntu 14.04

The output of uname -r is:


The output of dpkg --list | egrep -i --color 'linux-image|linux-headers' is

ii  linux-headers-3.19.0-32                     3.19.0-32.37~14.04.1                                all          Header files related to Linux kernel version 3.19.0
ii  linux-headers-3.19.0-32-generic             3.19.0-32.37~14.04.1                                amd64        Linux kernel headers for version 3.19.0 on 64 bit x86 SMP
ii  linux-image-3.19.0-32-generic               3.19.0-32.37~14.04.1                                amd64        Linux kernel image for version 3.19.0 on 64 bit x86 SMP
ii  linux-image-extra-3.19.0-32-generic         3.19.0-32.37~14.04.1                                amd64        Linux kernel extra modules for version 3.19.0 on 64 bit x86 SMP

Similar but not actually related posts

  • This one had similar errors, but was an issue with too many items in boot partition, which doesn't appear to be the case for me.

Potential Solutions?

  • I came accross this post which might be worth a try? It involves removing any lines of code related to the relevant package from the dpkg status file. But I am worried that removing kernel image information from this file might break my computer.

Instead of using --fix-broken/-f command to satisfy dependencies, you can try download and install the mentioned dependencies (linux-image-generic=

32 Bit: Download Link

64 Bit: Download Link

To install the .deb file, I recommend you to use gdebi package installer which also check the package dependencies and tell whether it's satisfied or not:

sudo apt install gdebi
sudo gdebi Downloads/linux-image-generic_3.

Replace arch with i386 (for 32 bit) or amd64 (for 64 bit).

  • 2
    Ohh, Brilliant !! :) Thank you so much, that did the trick. Instead of downloading those deb links, i forced a specific version on apt-get using sudo apt-get install linux-image-generic= But thank you so much for pointing this out and for going to the extra effort of finding those links.
    – ronrest
    Jan 11 '17 at 8:10
  • Glad it helped !
    – Liso
    Jan 11 '17 at 8:13

There may be something wrong. Your kernel was 3.19.0-32-generic based on uname -r output. But Ubuntu 14.04 latest kernel found on this link was That mean your kernel is ahead of the trusty repository source.

So, you may need to check repository list on /etc/apt/sources.list or you have installed 3.19.0-32 kernel manually.

Option 1

Please try with following command.

sudo apt install linux-image-generic-lts-vivid linux-image-extra-virtual-lts-vivid 

This may update your kernel to

Option 2

You can try to roll back your kernel to But this may need to take care. It is risky. If you agree you can reference this answer. And then install again with

sudo apt-get install linux-image-extra-$(uname -r) linux-image-extra-virtual

Please try the following command.

kern_extras="linux-image-extra-virtual linux-image-extra-$(uname -r)"
  • 2
    Welcome to the site and thank you for adding the answer, that you have. Please consider editing your answer to include more details such as what it does, how it will help and the expected outcome.
    – Phil UK
    Mar 30 '17 at 2:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.