When booting from a Live USB I'm getting an ISO Linux Error immediately after BIOS POST (Basic Input Output System Power On Self Test):

ISOLINUX 6.03 20160618 EHDD Copyright (c) 1994-2014 H. Peter Anvin et al

Loading bootlogo...
bootlogo: invalid file format
Error setting up gfxboot

 (repeats 2 times)

Loading bootlogo...
bootlogo: invalid file format
Error setting up gfxboot

Hard power-off.

I'm able to create a 4GB FAT32 Partition and 28GB NTFS partition with 512 Byte sectors but after using Startup Disk Creator or DD on the ISO file I end up with 2048 byte sectors that confuses gparted.

Although it's a UEFI machine CSM (Legacy BIOS boot) is enabled in BIOS.

Machine specifics:

  • Dell Inspiron 17R 7720 SE
  • Intel I7 3630QM 2.4 GHz, 3.4 GHz Turboboost
  • 8 GB DDR3 RAM
  • nVidia GeForce GT650M w/2GB RAM
  • Full size 240 GB Sata 3 SSD, Full size Sata 2 500 GB HDD
  • Mini PCIe mSata 128 GB Sata 3 SSD
  • Optical CD/DVD Caddy
  • Four USB 3.0 ports, one of them powered when machine is off.
  • Current BIOS A17
  • Ubuntu Intel Microcode via Additional Software Drivers
  • EUFI and Secure boot turned off

Update 1

$ lsblk -f
NAME   FSTYPE  LABEL             UUID                                 MOUNTPOINT
├─sda1 ntfs    System Reserved   FAC07A55C07A1859                     
├─sda2 ntfs    KSX_Win7          2EBA8445BA840B91                     
├─sda3 ntfs    KSX Win 8.1       8C3ADAA93ADA8F96                     
├─sdb1 ntfs    ST9_Win7          C2F48A08F489FF43                     
├─sdb2 ext4    ST9_Linux         bf80a37d-dfad-4df1-b8b1-a67ef2a9ab66 
└─sdb3 swap                      f7ca38bd-ccf1-4d61-b54b-017b1493d1b4 
├─sdc2 ntfs    F9m_Win7          5824BF4E76D68BE2                     
├─sdc3 ext4    F9m_Linux         d02dc21d-dcb2-478e-9f7d-9a3331931de4 /
└─sdc4 swap                      09606fe6-c131-43fc-9ebc-be05a96e1c1d [SWAP]
sdd    iso9660 Ubuntu 17.04 amd64
│                                2017-01-07-08-08-00-00               
├─sdd1 iso9660 Ubuntu 17.04 amd64
│                                2017-01-07-08-08-00-00               /media/ric
└─sdd2 vfat    Ubuntu 17.04 amd64

Update 2

Tried creating boot USB using SYSLINUX and same error as above occurs except "SYSLINUX" appears instead of "ISOLINUX" and only one line appears (the very top line).

Then using Rufus under Windows 8.1 created a boot USB with FreeDOS as the OS and this much more detailed error appeared:

Camera 20170111

  • 1) Please tell me from which iso file you are creating this USB boot drive - the file name as seen at the download site should be enough. - 2) Which version of the Startup Disk Creator causes this problem? - 3) Do you get this problem also when cloning with dd? - 4) What is the output of lsblk -f ? - 5) Does it boot ) - What you see in gparted is probably a bug. It does not understand hybrid iso files and the system they create in USB drives.
    – sudodus
    Jan 11, 2017 at 5:47
  • Try to switch to Legacy mode instead of EUFI. This will help and turn ON security boot. Jan 11, 2017 at 7:22
  • @JafferWilson Thank you for your comment. Legacy mode (aka CSM) is turned on. Jan 11, 2017 at 11:52
  • @sudodus 1) The ISO comes from Daily Build. First Attempt Dec 31, 2016. Second attempt Jan 3rd, 2017. Always same error screen on boot. 2) Startup Disk Creator version is Ubuntu 16.04. 3) Cloning ISO via dd gives the same screen. 4) lsblk -f output added to question. 5) It doesn't boot :( Jan 11, 2017 at 11:56
  • I think it is (was?) a bug, but it is strange, that you are affected by that isolinux bug and I am not. Maybe the bug was fixed during the three days between 2017-01-07 and 2017-01-10. Please try with the current iso file.
    – sudodus
    Jan 11, 2017 at 12:17

2 Answers 2


After googling many websites with Dell Inspiron USB Boot Error I found a link to these instructions (pendrivelinux.com - BIOS USB booting tips and tricks) which tells us to unplug all other USB devices:

  • Port 1 had extra power cable for charging USB devices next to laptop.
  • Port 2 had USB bootable flash drive that didn't work.
  • Port 3 had Logitech unifying receiver for K800 backlit keyboard and MX Pro mouse
  • Port 5 had 10 foot USB 3 cable to 7 port powered hub containing printer, UPS (Uninterruptable Power Supply) communications, cell phone and bluetooth headphone charging.

Unplugging everything except the USB Flash drive made USB boot successful:

DOS boot

  • Congratulations and thanks for sharing your solution :-) This is a good general advice - to unplug all other USB devices. I have read and written about it before, but I have neither read nor written about it recently. I'm glad you found it, and solved the problem with this Dell.
    – sudodus
    Jan 15, 2017 at 17:29
  • Thank you. When reading the link what clued me in was it said (para-phrasing): "we've even seen an iPod plugged in caused boot to fail". Immediately I thought of my cellphone and unplugged everything. I only wish I found this site years ago and saved hours of time waiting and listening to DVD chug along. Most of all thank you for your quick and generous offers of assistance! Jan 15, 2017 at 17:35

Replying to "Oh BTW still haven't got 17.04 live USB working yet on BIOS format on UEFI machine":

Yesterday (2017-01-10) I zsynced the daily Ubuntu Zesty amd64, cloned it with mkusb-dus (with dd under the hood).

  • It works live in my 3-4 year old Toshiba laptop in BIOS alias CSM mode (InsydeH2O rev. 3.7, System BIOS version 6.10 EC version 6.00). The screenshot illustrates this particular case:

enter image description here

  • It works in UEFI mode too in that computer.

  • It works in my newest computer, an Intel NUC6i3SYH in both BIOS and UEFI modes (Intel Visual BIOS SYSKLi35.86A.0024.2015.1027.2142)

I think what you see in gparted is caused by a bug in gparted. It does not understand hybrid iso files and the system they create in USB drives. But

sudo lsblk -fm

will show the partitions and ISO 9660 file system in a correct way.

So let us find out, if the problem is due to the iso file or the computer (your Dell). Cloning with dd is very reliable (when done correctly with or without help of a 'safety belt' shellscript).

  • It's nice to know 17.04 works for you. The installer is based on 16.10 so I had high confidence it does work. Making a USB 16.04 live USB results in same errors for me. Indeed the only live USB I've ever been able to make was in Sparky Linux a few years ago. Jan 11, 2017 at 11:59
  • @everybody: It would be interesting to find out if there are problems in BIOS mode in other computers too - If you, who are reading this, have problems to boot zesty (17.04) in BIOS mode, please tell us.
    – sudodus
    Jan 11, 2017 at 12:30
  • @ sudodus Just to be clear it's not a problem booting Zesty (17.04) in BIOS mode. it's a problem booting an installation USB downloaded from Ubuntu website. It applies to 16.04 and 14.04 as well. I should have pointed out the laptop has four USB 3.0 ports one of them powered when machine is off.. Jan 11, 2017 at 12:40
  • Now I don't understand. Which Ubuntu website has installation USBs to be downloaded, that would be different from the iso files?
    – sudodus
    Jan 11, 2017 at 13:02
  • I meant ISO that can be burned to optical or flashed to USB... Jan 11, 2017 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.