2

I have uninstalled wine after upgrading from 14.04 and now it's not installable anymore:

sudo apt install wine1.6

[..]
The following packages have unmet dependencies:
 wine1.6 : Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu14)
           Recommends: fonts-droid but it is not installable
E: Unable to correct problems, you have held broken packages.

When I'm tracing the issue, it looks like the library libldap-2.4-2:i386 doesn't seem to be installable. This begs the question, why d you even need to install a wine 386 version?

Is it intentional that wine is not installable without removing libreoffice and other packages that have the depencency libldap-2.4-2 in an amd64 version?


$ sudo apt update
Hit:1 http://ch.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://archive.canonical.com xenial InRelease                                                             
Hit:3 http://ppa.launchpad.net/fkrull/deadsnakes/ubuntu trusty InRelease                                        
Hit:4 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu xenial InRelease                               
Get:5 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Ign:6 http://security.ubuntu.com/ubuntu xenial-security/main Sources
Ign:7 http://security.ubuntu.com/ubuntu xenial-security/restricted Sources
Ign:8 http://security.ubuntu.com/ubuntu xenial-security/universe Sources
Ign:9 http://security.ubuntu.com/ubuntu xenial-security/multiverse Sources
Ign:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
Ign:11 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
Ign:12 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en
Get:13 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [68.0 kB]
Get:14 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [43.1 kB]
Ign:15 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
Ign:16 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages      
Ign:17 http://security.ubuntu.com/ubuntu xenial-security/restricted Translation-en
Ign:18 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 DEP-11 Metadata
Ign:19 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
Ign:20 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages
Ign:21 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en
Get:22 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [25.4 kB]
Get:23 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [31.8 kB]
Ign:24 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages
Ign:25 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages          
Ign:26 http://security.ubuntu.com/ubuntu xenial-security/multiverse Translation-en
Get:27 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 DEP-11 Metadata [212 B]
Ign:28 http://security.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 64x64 Icons
Ign:6 http://security.ubuntu.com/ubuntu xenial-security/main Sources                  
Ign:7 http://security.ubuntu.com/ubuntu xenial-security/restricted Sources
Ign:8 http://security.ubuntu.com/ubuntu xenial-security/universe Sources
Ign:9 http://security.ubuntu.com/ubuntu xenial-security/multiverse Sources
Ign:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
Ign:11 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
Ign:12 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en
Ign:15 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages
Ign:16 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages
Ign:17 http://security.ubuntu.com/ubuntu xenial-security/restricted Translation-en
Ign:18 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 DEP-11 Metadata
Ign:19 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages
Ign:20 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages
Ign:21 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en
Ign:24 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages                              
Ign:25 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages                               
Ign:26 http://security.ubuntu.com/ubuntu xenial-security/multiverse Translation-en                              
Ign:28 http://security.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 64x64 Icons                          
Get:6 http://security.ubuntu.com/ubuntu xenial-security/main Sources [64.9 kB]                                  
Get:7 http://security.ubuntu.com/ubuntu xenial-security/restricted Sources [1'872 B]                            
Get:8 http://security.ubuntu.com/ubuntu xenial-security/universe Sources [18.6 kB]                              
Get:9 http://security.ubuntu.com/ubuntu xenial-security/multiverse Sources [642 B]                              
Get:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [250 kB]                           
Get:11 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [241 kB]                            
Get:12 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [116 kB]                           
Get:15 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages [11.7 kB]                    
Get:16 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages [11.7 kB]                     
Get:17 http://security.ubuntu.com/ubuntu xenial-security/restricted Translation-en [2'044 B]                    
Err:18 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 DEP-11 Metadata                       
  Could not open file /var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_xenial-security_restricted_dep11_Components-amd64.yml.gz - open (13: Permission denied) [IP: 91.189.88.161 80]
Get:19 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [83.4 kB]                      
Get:20 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [78.9 kB]                       
Get:21 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [45.6 kB]                      
Get:24 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages [2'941 B]                    
Get:25 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages [3'128 B]                     
Get:26 http://security.ubuntu.com/ubuntu xenial-security/multiverse Translation-en [1'053 B]                    
Ign:28 http://security.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 64x64 Icons                          
Fetched 871 kB in 8s (103 kB/s)                                                                                 
Reading package lists... Done
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/restricted/dep11/Components-amd64.yml  Could not open file /var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_xenial-security_restricted_dep11_Components-amd64.yml.gz - open (13: Permission denied) [IP: 91.189.88.161 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
2
  • Whats the output of sudo apt update? Edit your question with it please :) – M. Becerra Jan 10 '17 at 21:11
  • I have added the apt update output. I don't feel like there's anything peculiar. – David Halter Jan 10 '17 at 22:15
6

Turned out it was an inconsistent state of my 16.04. I don't know how I got there (since I don't really use ppas). However installing wine 1.6 is possible. You can try to resolve the problem with aptitude. Just use R# (where # has to be replaced by the number that you see on your screen, in my case 6) to resolve issues.

According to my Debian-savvy friend downgrading of packages doesn't have a high priority (which means that you will normally not see that as a solution).

sudo aptitude install wine

[...]

The following actions will resolve these dependencies:

      Keep the following packages at their current version:
1)      libldap-2.4-2:i386 [Not Installed]                 
2)      libosmesa6 [Not Installed]                         
3)      libosmesa6:i386 [Not Installed]                    
4)      p11-kit-modules:i386 [Not Installed]               
5)      wine [Not Installed]                               
6)      wine1.6 [Not Installed]                            
7)      wine1.6-amd64 [Not Installed]                      
8)      wine1.6-i386:i386 [Not Installed]                  

      Leave the following dependencies unresolved:         
9)      wine1.6-amd64 recommends libosmesa6                
10)     winetricks recommends wine                         
11)     wine1.6-i386:i386 recommends libosmesa6:i386       
12)     wine1.6-i386:i386 recommends p11-kit-modules:i386  


Accept this solution? [Y/n/q/?] R6
Rejecting the removal of wine1.6
The following actions will resolve these dependencies:

      Keep the following packages at their current version:
1)      libldap-2.4-2:i386 [Not Installed]                 
2)      libosmesa6 [Not Installed]                         
3)      libosmesa6:i386 [Not Installed]                    
4)      p11-kit-modules:i386 [Not Installed]               
5)      wine [Not Installed]                               
6)  R   wine1.6 [Not Installed]                            
7)      wine1.6-amd64 [Not Installed]                      
8)      wine1.6-i386:i386 [Not Installed]                  

      Leave the following dependencies unresolved:         
9)      wine1.6-amd64 recommends libosmesa6                
10)     winetricks recommends wine                         
11)     wine1.6-i386:i386 recommends libosmesa6:i386       
12)     wine1.6-i386:i386 recommends p11-kit-modules:i386  


Accept this solution? [Y/n/q/?] n

The following actions will resolve these dependencies:

     Keep the following packages at their current version:                          
1) R   libosmesa6 [Not Installed]                                                   
2)     libosmesa6:i386 [Not Installed]                                              

     Downgrade the following packages:                                              
3)     libldap-2.4-2 [2.4.42+dfsg-2ubuntu3.1 (now) -> 2.4.42+dfsg-2ubuntu3 (xenial)]
4)     libp11-kit0 [0.23.2-5~ubuntu16.04.1 (now) -> 0.23.2-3 (xenial)]              
5)     libp11-kit0:i386 [0.23.2-5~ubuntu16.04.1 (now) -> 0.23.2-3 (xenial)]         
6)     p11-kit [0.23.2-5~ubuntu16.04.1 (now) -> 0.23.2-3 (xenial)]                  
7)     p11-kit-modules [0.23.2-5~ubuntu16.04.1 (now) -> 0.23.2-3 (xenial)]          

     Leave the following dependencies unresolved:                                   
8)     wine1.6-amd64 recommends libosmesa6                                          
9)     wine1.6-i386:i386 recommends libosmesa6:i386                                 


Accept this solution? [Y/n/q/?] Y
The following packages will be DOWNGRADED:
  libldap-2.4-2 libp11-kit0 libp11-kit0:i386 p11-kit p11-kit-modules 
The following NEW packages will be installed:
  fonts-horai-umefont{a} fonts-unfonts-core{a} fonts-wqy-microhei{a} gnome-exe-thumbnailer{a} icoutils{a} libasn1-8-heimdal:i386{a} libcapi20-3{a} libcapi20-3:i386{a} libexif12:i386{a} libgd3:i386{a} 
  libgif7{a} libgif7:i386{a} libglu1-mesa:i386{a} libgphoto2-6:i386{a} libgphoto2-port12:i386{a} libgssapi3-heimdal:i386{a} libhcrypto4-heimdal:i386{a} libheimbase1-heimdal:i386{a} 
  libheimntlm0-heimdal:i386{a} libhx509-5-heimdal:i386{a} libieee1284-3:i386{a} libkrb5-26-heimdal:i386{a} libldap-2.4-2:i386{a} libltdl7:i386{a} libmpg123-0:i386{a} libopenal1:i386{a} 
  libp11-kit-gnome-keyring:i386{a} libroken18-heimdal:i386{a} libsane:i386{a} libsasl2-2:i386{a} libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} libusb-1.0-0:i386{a} libv4l-0:i386{a} 
  libv4lconvert0:i386{a} libvpx3:i386{a} libwind0-heimdal:i386{a} libxcomposite1:i386{a} libxcursor1:i386{a} libxinerama1:i386{a} libxpm4:i386{a} libxrandr2:i386{a} ocl-icd-libopencl1:i386{a} odbcinst{a} 
  odbcinst1debian2{a} p11-kit-modules:i386{a} p7zip{a} ttf-wqy-microhei{a} unixodbc{a} wine wine-gecko2.21{a} wine-gecko2.21:i386{a} wine-mono0.0.8{a} wine1.6{a} wine1.6-amd64{a} wine1.6-i386:i386{a} 
  winetricks{a} 
The following packages are RECOMMENDED but will NOT be installed:
  libosmesa6 libosmesa6:i386 
0 packages upgraded, 57 newly installed, 5 downgraded, 0 to remove and 0 not upgraded.
Need to get 151 MB of archives. After unpacking 483 MB will be used.
Do you want to continue? [Y/n/?]

As you can see there, after rejecting the first solution we get to a point where libldap will be "downgraded". However it doesn't look like a real downgrade. It looks more like it's pushed towards an official version.

1
  • It's works perfectly I try it on my VPS server with ubuntu 14.04 – Salem F Sep 24 '19 at 20:54
0

why d you even need to install a wine 386 version?

Wine does not supply 64 bit binaries. You should also install wine 1.8 on 16.04. Not the old 1.6.

You probably did not completely remove the old wine. Do a ...

dpkg-query --list 'wine*'

Lines with ii means installed. Purge them. Do a ...

which wine

and make sure all references are removed. Then do a ...

sudo apt-get autoremove

At this point your system should be clean of wine. Also check your home for wine related directories (ls -la to list hidden). Remove those too.


Install wine from the devel version.

sudo add-apt-repository ppa:wine/wine-builds
sudo apt-get update
sudo apt-get install --install-recommends winehq-devel

and use winecfg to install all the requirements.

Also install winetricks from the wine website.

1
  • It doesn't seem to help if I use a ppa. There's still the libldap-2.4-2 conflict. dpkg-query --list 'wine*' lists nothing. I have purged all of that stuff (and autoremoved). I feel like there's nothing wine related left, but I might be wrong. – David Halter Jan 10 '17 at 22:13
0

Perhaps install a new version of wine, plenty of new versions have been released besides 1.6, maybe 1.8 or 1.9? Newer versions means they're updated and maybe the compatibility (among other issues) could be resolved.

1
  • Installing wine 1.8 has the exact same issue. – David Halter Jan 11 '17 at 11:52
0

The i386 architecture needs to be enabled before installing Wine 1.6.

Make sure you do

sudo dpkg --add-architecture i386
sudo apt update
sudo apt install wine

Not quite the OP's problem but this is the first result on Google for my error so thought this solution would be helpful to post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.