3

Product Name: HP Spectre x360 Kaby Lake Operating System: Ubuntu 16.10

I have Ubuntu 16.10 installed on Hp Spectre x360 Kaby Lake, I have noticed that on suspending the machine isnt exactly saving power - the battery discharge rate seems to be stable at the idle discharge rate?

Morover I have also noticed that the machine was a bit warm after a few hours, which makes me think that the machine was actually on but only the screen was off.

Any sugessions on how I can get the same suspend features as in Windows 10?

5
  • 3
    I'm not surprised, as Kaby Lake is quite new and kernel support isn't great yet. What kernel are you on?
    – negusp
    Jan 10 '17 at 16:23
  • $ uname -a Linux x360 4.8.0-32-generic #34-Ubuntu SMP Tue Dec 13 14:30:43 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
    – v2.
    Jan 11 '17 at 21:52
  • Have you tried installing 4.9?
    – negusp
    Jan 11 '17 at 23:51
  • I have tired the following without any luck uncommenting HandleLidSwitchDocked=suspend in /etc/systemd/logind.conf Not tired 4.9, may give it a shot after some risk assessment, since this my primary driver
    – v2.
    Jan 12 '17 at 9:24
  • Waiting for Ubuntu 17.04, fingers crossed will use kernel 4.10
    – v2.
    Feb 6 '17 at 9:40
1

For the moment, this problem would be solved by adding HandleLidSwitchDocked=suspend in /etc/systemd/logind.conf and then rebooting.

In my environment, adding the line fixes the problem.

My environment: Ubuntu 16.10, HP Spectre x360 Kaby Lake

$ cat /proc/cpuinfo | grep "model name"
model name  : Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
model name  : Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
model name  : Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
model name  : Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
$ uname -a
Linux nek-HP-Spectre-x360-Convertible-13-ac0XX 4.8.0-41-generic #44-Ubuntu SMP Fri Mar 3 15:27:17 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.10
Release:    16.10
Codename:   yakkety

For the detail, look at this bug: "Notebook doesn't suspend when lid is closed after update to 16.04"

1
  • I tried that, but no luck.
    – v2.
    Jul 11 '17 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.