4

I am running Ubuntu 16.04 and Emacs 25.1.2, which I installed from here:

https://launchpad.net/~kelleyk/+archive/ubuntu/emacs

According to:

Emacs toolbar icons missing in Ubuntu-16.10, struggle to compile emacs24 and 25

the kellyk build should resolve the empty menu problem, but I still get some empty menus, for example when I open a .tex file, the Latex menu is just a grey rectangle if I click on the menu. The menu only becomes populated when I hit F10, but I was wondering if anyone knows how to fix it so that I can click on it.

6

Rough answer:

I assume that you are using Unity. I haven't tested this, but I think that

gsettings set com.canonical.unity-gtk-module blacklist "['emacs25']"

should partially solve the issue — your compiled emacs will no longer use the Global Menu, but its own menu, which should be better-behaved. If needed, you can have a longer list of elements in the blacklist — e.g. "['emacs25', 'emacs26']". Restart Emacs after executing the above command!

(Possibly first run:

gsettings get com.canonical.unity-gtk-module blacklist

to ensure that the list is empty to begin with, and you're not clobbering anything.)

Brief explanation:

emacs24 from the default repositories has a hardcoded blacklist, but this does not carry over to emacs25.

Note: you might need to use the utility xprop (e.g. with xprop WM_CLASS — you need the first of the displayed strings) to determine the "WM_CLASS" of your emacs window and use that instead of emacs25.

  • I tried this, still doesn't work. – bkmoney May 17 '17 at 2:14
  • @bkmoney Did you restart emacs after doing this? Just checking :) – NeilenMarais Jun 6 '17 at 9:20
  • 1
    This problem still exists in 17.10. @aplaice's answer works as described after restarting emacs. – Reece Jan 1 '18 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.