0

Every time I open up emacs, I tend to get this text on my screen.. How do I permanently hide it? Thanks!

http://imgur.com/a/9KdHt

  • Does this help? How do I change the scratch message in Emacs? – steeldriver Jan 10 '17 at 2:50
  • yeah! I am a little new to emacs.. How do I actually execute this command? is it "m-!" but where do I add "(setq inhibit-startup-message t)" to to disable that scratch message? Thanks! – Kdrumz Jan 10 '17 at 4:44
0

According to this related StackOverflow answer How do I change the scratch message in Emacs?, you can suppress the message by setting

(setq initial-scratch-message nil)

in your configuration. If you don't already have a personal configuration file (usually ~/.emacs or ~/.emacs.d/init.el you can create one, using emacs or otherwise, and simply paste the command in verbatim, then save and exit. Next time you start emacs, the scratch buffer should be empty.

  • I am running both those commands and they are not working ~/.emacs.d/init.el and I get nothing exists. When I run **~/.emacs ** I get permission denied, then I run my terminal as root and it says directory doesn't exist. Does this have to be created and if so, how do I do this and where do I have to save it to? Also, when I open up emacs, what is the key combination to start typing in the verbatim, or the very bottom of the screen? I can't seem to figure this out. Thanks! – Kdrumz Jan 10 '17 at 18:18
  • @Kdrumz you don't run them, you edit them e.g. open them in emacs or nano ~/.emacs.d/init.el and type/paste the command in – steeldriver Jan 10 '17 at 18:21
  • okay, i just did that. When I open emacs, the buffer is still there.. What did I do wrong? imgur.com/a/XZmS3 – Kdrumz Jan 10 '17 at 18:35
  • This is also showing up when I open up a blank .cpp file imgur.com/a/UxMFw I have never had these problems when using emacs, should I just uninstall it and try again? – Kdrumz Jan 10 '17 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.