2

I have 2 displays of different resolutions. My primary is 1366x768, and my secondary is 1440x900.

My primary monitor, when set to its native resolution will leak onto my secondary display by 1 row. It's impossible to show in a screenshot. I have experienced this in Ubuntu 14.04 and 16.04 using both the default display drivers and proprietary. No change. The only workaround that I have currently is to lower the resolution on my primary.

Has anybody else experienced this issue, or is capable of reproducing it?

As always, more information will be provided when asked.

EDIT Output from xrandr | grep -w connected

eDP connected primary 1366x768+0+247 (normal left inverted right x axis y axis) 344mm x 194mm
HDMI-0 connected 1440x900+1366+0 (normal left inverted right x axis y axis) 408mm x 255mm
  • Can you add the output of xrandr | grep -w connected? – Terrance Jan 10 '17 at 0:48
  • Updated original post. Please excuse formatting errors, my network is being uncooperative and I copied the statement from mobile. – skeeter_mcbee Jan 10 '17 at 2:11
  • 1
    you can try setting your display manualy with xrandr xrandr --output HDMI-0 --pos 1366+0 since the eDP display bleeds onto the HDMI display increasing the 1366 could move the display out of the overlap if you mess up you can use the xrandr --output HDMI-0 --pos 1366+0 to reset to current setting – WooJoo Jan 10 '17 at 2:29
  • 1
    Thanks. I was able to fix it by adding 2 pixels to the width. See updated original post. – skeeter_mcbee Jan 10 '17 at 2:50
  • 1
    @skeeter_mcbee you will need to apply this change on every login. To do this you can add the command you used to your .xprofile in your home directory. your case xrandr --output HDMI-0 --pos 1368x0 – WooJoo Jan 10 '17 at 2:55
1

In my case, the fix was to adjust the position of the second monitor through xrandr. Adjusting the position by one pixel did not help, so I adjusted it by 2 and it works just fine. I used the following command:

sudo xrandr --output HDMI-0 --pos 1368x0

And then creating a file in my home directory called .xprofile and reentering the command; so it will set the position every time I log in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.