0

I tried to install libimobiledevice only to see that I get the following error:

sudo apt-get install libimobiledevice
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libimobiledevice

I found this page which I try to follow, but there was no file /etc/apt/sources.list.d/pmcenery.list I can edit, only a file /etc/apt/sources.list.d/pmcenery-ppa-trusty.list in which I replaced the line

deb http://ppa.launchpad.net/pmcenery/ppa/ubuntu trusty main

with

deb http://ppa.launchpad.net/pmcenery/ppa/ubuntu maverick main

But after that (and apt-get update) the same error remains. I can even produce another error as follows:

sudo apt-get install libimobiledevice1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libimobiledevice1 : Depends: libtasn1-3 (>= 1.6-0) but it is not installable
E: Unable to correct problems, you have held broken packages.

How can I install libimobiledevice on Ubuntu 14.045 LTS in order to transfer music files (mp3) to an iphone 6, so I can listen to the music on this very iphone 6?

1

You can use it to mount iPhone with the ifuse tool. So after you install libimobiledevice6 as you did, you mount the iPhone with ifuse.

But first you need to install some packages including what you installed. To help others who see this question I'll explain how I do it from scratch:

sudo apt-get install ideviceinstaller python-imobiledevice libimobiledevice-utils libimobiledevice6 libplist3 python-plist ifuse

Then plug in the iPhone to a USB port and pair the iPhone:

idevicepair pair

Note: if you get an error "ERROR: Could not validate with device xxxxxxxxxx because a passcode is set. Please enter the passcode on the device and retry." unlock the iPhone and choose "Trust" in the security popup and repeat the command above.

Next you mount the iPhone with ifuse:

ifuse /media/iPhone/

You can run ifuse command above as root (sudo) or as a regular user, depending if you want to allow users to mount and unmount your iPhone.

To unmount the iPhone, which you should do to avoid problems mounting in future use the following commands one after the other:

fusermount -u /media/iPhone/
idevicepair unpair

More info here: http://www.dedoimedo.com/computers/linux-iphone-6.html

  • Doesn't work. Says "Failed to connect to lockdownd service on the device." – Dims Aug 19 '18 at 15:26
0

The PPA you added is outdated - the need to change to "maverick" should have been a clue - so now it needs to be removed before adding the correct one:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:pmcenery/ppa

(or just remove it and run sudo apt-get update since you actually didn't install anything from it)

Install using

sudo add-apt-repository ppa:martin-salbaba/ppa+libimobiledevice
sudo apt-get update
sudo apt-get install libimobiledevice

All the dependencies should be pulled from this repository.

Please note that it may not work for your intended purpose. You are always at the mercy of a Linux-unfriendly manufacturer. News & updates at http://www.libimobiledevice.org/

  • 1
    With the last command I get the same error as before (E: Unable to locate package libimobiledevice), but the following worked: sudo apt-get install libimobiledevice6. As I suppose this is a library ('lib-imobile-device'), how is it supposed to work? – Alex Jan 10 '17 at 11:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.