2

It used to work but I guess one of the updates broke it. I can connect to the wifi on my phone and other OS's. Unsure of what would cause this. I have tried deleting the profile for each connection and re-entering passwords but nothing. IF I remove passwords for the connections it will work.

3
  • Recently I had a similar problem. I had disabled WMM on the router and this caused the problem. There was some info about it in dmesg. Try to sign into the network and then check dmesg for any new info. If you don't find any useful info, please post the info described here: askubuntu.com/questions/425155/… thanks!
    – mchid
    Jan 9 '17 at 19:59
  • I have WMM enabled. I have this error "ADDRCONF(NETDEV_UP): wlp3s0: link is not ready" when I run dmesg
    – Derek
    Jan 9 '17 at 23:51
  • Okay, just follow the instructions outlined in the following link to provided the information needed to diagnose the issue please: askubuntu.com/a/425205/167115 thanks!
    – mchid
    Jan 10 '17 at 13:53
4

Try this if you have network-manager enabled :

sudo nmcli dev wifi 

to find your wifi ssid and

sudo nmcli dev wifi connect <your ssid> password <your pass>

Looks like network-manager is waiting for root permission.

1
  • It worked! Thanks, although the only bad thing is that, in your bash history the wifi password, will remain visible.
    – Edenshaw
    Nov 27 '17 at 12:44
2

If you don't want your password to appear in your history just leave out the password part and add the -a option and it will ask for it after you hit enter:

 sudo nmcli -a dev wifi connect <your ssid>

From man nmcli

 -a | --ask    When using this option nmcli will stop and ask for any missing 
  required arguments, so do not use this option for non-interactive purposes like
scripts. This option controls, for example, whether you will be prompted for a 
password if it is required for connecting to a network.
0

It happened to me and I hadn't done anything. Turned out there was something wrong with the "Bbox" from Bouygues ISP. After 2 hours on the phone they sorted it out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.