0

I'm trying to install Docker on my workstation Ubuntu 14.04 LTS following : https://docs.docker.com/engine/installation/linux/ubuntulinux/

When I do :

sudo apt-get install linux-image-extra-$(uname -r)

It says "linux-image-extra-3.13.0-39-generic" is already up do date, but when I do :

sudo apt-get install linux-image-extra-virtual

It says (sorry it's in french) :

Les paquets suivants contiennent des dépendances non satisfaites :
 linux-image-extra-virtual : Dépend: linux-image-generic (= 3.13.0.24.28) mais 3.13.0.39.46 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Google translator gives :

The following packages contain unsatisfied dependencies:
 linux-image-extra-virtual: Depends on: linux-image-generic (= 3.13.0.24.28) but will need to be installed 3.13.0.39.46
E: Unable to correct problems, defective packages are in "keep as is" mode.

EDIT 2 : the real error message is :

E: Unable to correct problems, you have held broken packages

which means if I understand linux-image-generic is not the version expected but can't be upgraded since it's in "keep as it is" mode.

What can I do to install Docker from there ?

EDIT : before installation, I've done :

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
0
0

Ok, I solved it. The french message is just wrong, it's not "but 3.13.0.39.46 will have to be installed", it's "but 3.13.0.39.46 IS installed", so it was requesting for a downgrade.

When u do the same with aptitude, u get the right message, and it proposes you to downgrade.

0

I solved a similar but not the same error just now when I tried to install docker on my Ubuntu 14.04 with "4.4.0-75-generic" kernel version.

The error info is:

Setting up linux-image-extra-3.13.0-119-generic (3.13.0-119.166) ...

run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-119-generic /boot/vmlinuz-3.13.0-119-generic

run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-119-generic /boot/vmlinuz-3.13.0-119-generic

update-initramfs: Generating /boot/initrd.img-3.13.0-119-generic

run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-119-generic /boot/vmlinuz-3.13.0-119-generic

run-parts: executing /etc/kernel/postinst.d/statoverride 3.13.0-119-generic /boot/vmlinuz-3.13.0-119-generic

dpkg-statoverride: error: an override for '/boot/vmlinuz-3.13.0-119-generic' already exists; aborting

run-parts: /etc/kernel/postinst.d/statoverride exited with return code 2 dpkg: error processing package linux-image-extra-3.13.0-119-generic (--configure):

subprocess installed post-installation script returned error exit status 1 No apport report written because MaxReports is reached already

dpkg: dependency problems prevent configuration of linux-image-generic: linux-image-generic depends on linux-image-extra-3.13.0-119-generic; however: Package linux-image-extra-3.13.0-119-generic is not configured yet.

dpkg: error processing package linux-image-generic (--configure): dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of linux-image-extra-virtual: linux-image-extra-virtual depends on linux-image-generic (= 3.13.0.119.129); however: Package linux-image-generic is not configured yet.

My solution referred to this answer at #28:

[jeremy@compute]$ su - root [root@compute]# cp /etc/kernel/postinst.d/statoverride ~/ [root@compute]# sed -i '/dpkg-statoverride/s/$/||:/' /etc/kernel/postinst.d/statoverride

Hope it is helpful to others who encounter it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.