14

How to install & run Xmind v8.0 in Ubuntu 16.4 (ZIP file) with command line ?

20

@Rinzwind is cheating :)

In case you are using the "regular" -official Xmind -version for Linux:


Xmind used to be available as .deb file, but from version 8, there is currently no .deb file available. It can still be run very well on Debian-based systems however.

How to use

The most easy setup is to run it locally, since the application needs to be in a writable directory. The application comes with a setup.sh. Unlike what you would expect, this does not install the application itself, but it installs a few shared libraries it uses, and a few fonts to be used with Xmind.

  1. Download the latest Xmind from here (.zip)
  2. Unzip xmind-8-linux.zip, move the unzipped folder to any location you like where you have write permissions
  3. Open the folder (or cd into it if you are on cli), and run the setup.sh script with sudo, to install some libraries and fonts (simply type sudo and drag the script on to a terminal window and press Enter).
  4. Now we will run Xmind for the first time, during which we will be able to create a launcher for Dash and the Unity Launcher:

    • Inside the xmind-8-linux folder, open either the XMind_amd64 or XMind_i386 folder, depending on your architecture, and double click on the Xmindexecutable. The application will start.
    • In the Unity Launcher, the Xmind icon will appear. Right-click on the icon and choose "Add to Dash"

      enter image description here

    • Log out and back in, and your setup is ready to use, Xmind is available to Dash.

Explanation

To run Xmind, you can create a .desktop file manually, however, you can also let Unity do the job for you, as explained here and here. An Xmind icon is automatically copied to ~/.local/share/icons/xmind.png for local use.

Note

I tried the latest version (8) of Xmind for a few hours, and to be honest, I prefer previous version(s) with less (or no) "advertising", and a more intuitive interface (which is opinion-based of course).

It seems I am not the only one in that, since Xmind makes previous versions available here. These version(s) include .deb installers. These versions run perfectly fine on 16.04.

20

Download this link http://www.xmind.net/xmind/downloads/xmind-8-beta-linux_amd64.deb

Either doubleclick the finished download in your ~/Downloads and let software center install it.

Or enter commandline and do

dpkg -i xmind-8-beta-linux_amd64.deb

on the finished download.

The 1st should be preferred. The 2nd would require you to download and install all the dependencies manually too.

  • 1
    You are a cheater! :) – Jacob Vlijm Jan 9 '17 at 14:24
  • 1
    Just curious, how did you find this one? It is not here: xmind.net/download/linux – Jacob Vlijm Jan 9 '17 at 14:28
  • 3
    I googled it :D :D xmind.net/download/beta – Rinzwind Jan 9 '17 at 14:33
  • 1
    I did too, but no matches to .deb i.c.w. xmind. It must be a conspiracy... – Jacob Vlijm Jan 9 '17 at 14:35
  • 3
    Zip tends to be WINDOWS. You need .DEB. A zip in linux would be a source file so a DEB is preferred (since Ubuntu used DEB natively) – Rinzwind Jan 9 '17 at 14:44
2

I have written a bash for installing XMind from zip file.

Here is Github repo https://github.com/dinos80152/XMind-Linux-Installer

The installation includes

  1. Installing dependencies
  2. Extracting xmind zip file to /opt/xmind
  3. Creating XMind command
  4. Creating launcher, MIME and icon
  5. Creating workspace
  6. Setting XMind.ini
  7. Updating MIME database, Desktop database, and font cache

Everything is done by one script, you don't have to do anything else by yourself. The /usr folder is copied from XMind 8 beta version deb file.

It also has an uninstall bash script.

Any question and advice, leave issues in github repo.

2

If after installing XMind, any method you can not launch it as stated by @quickstop. The problem may be with the way Java 9/10/11 treats the classpath, it seems that Xmind is using an old eclipse version.

The trick is to tell eclipse to use a Java 8 version.

./XMind -vm /usr/lib/jvm/java-8-openjdk-amd64/bin/java

Tells eclipse to look for java at /usr/lib/jvm/....

BTW the deb file contains an older version of Xmind.

If you do not want to use a command line modifier you can always include the

-vm <your path to java exec>

flag in the XMind.ini file

1

SOLUTION: Script file that installs XMind 8


I'm very surprised that XMind has left the Unix users with such frustration for installing XMind 8.

To solve the problem I wrote a bash script that installs XMind 8. I have tested it with Ubuntu 16.04.2. This will also install the XMind menu item and its icon.

#!/bin/bash
 #xmind8Install.sh

usage=$(cat << EOM

USAGE: -This script works with "XMind_amd64" only (not i386, 32-bit)! Tested with Ubuntu 16.04.2 -Best to just copy this script file into the same directory as the downloaded xmind-8-update1-linux.zip file (or whatever you called it). -This script will create a final direcoty 'xmind8' to install into but you need to pick where you want that 'xmind8' directory if you don't want the default of '$HOME/.local/bin'.

xmind [/path/to/downloaded_xmind_file-name.zip] [/path/to/where/you/want/to/install (DEFAULT: $HOME/.local/bin)]

EXAMPLE: sudo bash $0 xmind-8-update1-linux.zip sudo bash $0 Downloads/xmind-8.zip sudo bash $0 xmind-8-update1-linux.zip $HOME/apps sudo bash $0 xmind-8-update1-linux.zip /opt \n EOM )

[[ ($# < 1) || ("$1" == "--help") || ("$1" == "-h") || ("$1" == "-H") ]] && echo -e "${usage}" #Displays help/usage info

function fCHECKSUDO { # checks to make sure the script is being run as root if [ "$(id -u)" != '0' ] then echo -e "\n $(tput setaf 1)This script has to be run as root! ($ sudo bash ...)$(tput setaf 9)\n" exit 1 fi } fCHECKSUDO

type unzip >/dev/null 2>&1 || { apt-get install -y unzip; } #This installs the package 'unzip' if it is not already installed. fileZip="${1}" installDirRoot="${2:-"$HOME/.local/bin"}" #echo '$fileZip='$fileZip " " '$installDirRoot='$installDirRoot

function _installXMind8 { ##user preferences seemed to be saved into: xmind/workspace/.metadata/.plugins/org.eclipse.core.runtime/.settings/ ##http://www.xmind.net/m/PuDC a beta DEB package ##To find the icon images: $ find ~/bin/xmind8 -iname xmind.*.png #[[ ! -f "$fileZip" ]] && wget -t 4 -O xmind8.zip "https://www.xmind.net/xmind/downloads/xmind-8-update1-linux.zip" ##xmind.net is blocking non-browser downloads [[ ! -d "$installDirRoot" ]] && mkdir -pv "$installDirRoot" unzip "$fileZip" -d "$installDirRoot/xmind8" "$installDirRoot/xmind8/setup.sh"

xmindini="$installDirRoot/xmind8/XMind_amd64/XMind.ini" cp $xmindini ${xmindini}.BAK oneDot="${installDirRoot}/xmind8/XMind_amd64/" twoDot="${installDirRoot}/xmind8/" sed -i "s/^.//${oneDot////\/}/g" $xmindini sed -i "s/^..//${twoDot////\/}/g" $xmindini

cat <<-EOF > $HOME/.local/share/applications/xmind.desktop [Desktop Entry] Type=Application Name=XMind Comment=Create and share mind maps. Exec=$installDirRoot/xmind8/XMind_amd64/XMind %f Categories=Office; NoDisplay=false MimeType=application/zip Terminal=false Icon=$installDirRoot/xmind8/XMind_amd64/configuration/org.eclipse.osgi/981/0/.cp/icons/xmind.64.png EOF

chown -R ${HOME//\/home\//}:${HOME//\/home\//} $installDirRoot chown -R ${HOME//\/home\//}:${HOME//\/home\//} $HOME/.local/share/applications/xmind.desktop } _installXMind8

Newbie instructions for how to install XMind8 with this script:

1) Download XMind 8 zip file (which you probably already have and it is why you are here now).
2) Create an empty file $ touch xmind8Install.sh in the same directory where you have saved the xmind-8-update1-linux.zip file you have downloaded.
3) Copy-paste the contents of the above bash script into the file xmind8Install.sh
4) run $ bash xmind8Install.sh --help for usage info.

for example: $ sudo bash xmind8Install.sh xmind-8-update1-linux.zip

0

I've tried instructions from official site: http://www.xmind.net/m/PuDC (text instruction you can find at the bottom of page) with Ubuntu 16.04.2 (x64). Works fine!

Also, if you have fresh ubuntu installation (as I have), you probably need java to be installed: sudo apt-get install default-jre

And icon, it didn't appear out of the box, so I've downloaded png manually and specified in .desktop file, smth. like:

Icon=/opt/xmind/XMind_6_icon.png
  • Share detail of the solution. The link can be useful only for giving reference or more detail – Mostafa Ahangarha Mar 20 '17 at 18:43
0

I was able to get Xmind 8 update2 to install and function in Ubuntu 17.04 after installing Oracle Java 8. Xmind 8 does not seem to function with openjdk (any version).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.