I installed my XFX 2GB RX 460 Graphics card last week and it's been working good on Windows 7, however, when I tried installing the drivers in 16.10 I found out they're not out there yet (had a login loop) and 16.04 drivers AMDGPU-Pro are not compatible with 16.10 so I downgraded to 16.04.

When I tried logging in with 16.04 I found out my drivers weren't compatible either I can only access TTY, I can't even see the login screen, tried using ubuntu-devices and other fixes I found on the web but nothing worked. Lastly I read that you had to downgrade to 14.04 so I did but I found the same error, a window telling me my drivers are not compatible and that I will use simple graphics for one session, but the only thing it shows is the tty console, tried doing apt-get update and apt-get update from there but it didn't work either.

I'm writing from my Windows partition right now, I really wanted to be able to run my graphics card in Ubuntu so I could get rid of Windows for good but I think it won't happen.

I don't know what else to do to at least try get some visual enverioment in Ubuntu with my new RX 460.

Hope someone with the same problem has fixed it and is willing to help. Thanks in advance.

  • Its possible. Give me time to write down ! – ankit7540 Jan 10 '17 at 6:01
up vote 2 down vote accepted

The only way I've had success in getting the sound to work through HDMI is with the amd-pro driver from AMD.

I've had success with kernel's 4.4 and 4.8 only, 4.9 seems to break the "HDMI" sound again.

As ankit7540 pointed out, that page has step by step instructions for installing on Ubuntu ie.

tar -Jxvf amdgpu-pro-16.60-379184.tar.xz

cd amdgpu-pro-16.60-379184

./amdgpu-pro-install -y

Also, once installed you will need to be added to the "video" group or the sound wont actually work.

sudo usermod -a -G video $LOGNAME

A restart is required after to make everything work.

This only works for Ubuntu and its various flavors, I tried on Mint and it wont install.

The other thing I noticed if your accessing the AMD pages via Google is, if you download the pro driver from the front page rather than the instructional page you will get an older driver 16.40.

This link gives you the latest version 16.60...

https://www2.ati.com/drivers/linux/ubuntu/amdgpu-pro-16.60-379184.tar.xz

One more thing to note is, if you really want to use the open source driver you will need to wait for kernel 4.11 or use some trickery, mentioned here...

https://forums.linuxmint.com/viewtopic.php?t=238028#p1268156

  • This worked for me! amdgpu-pro 16.60 and Kernel 4.8.5 – David Merinos Mar 25 '17 at 0:38
  • I must add, however, that dual screen doesn't seem to work as in Windows, I have 2 screens, one with an HDMI Adapter connected to the graphics card (works in Ubuntu), and another one VGA connected to the motherboard (doesn't work in Ubuntu) whilst they both work in Windows 10. – David Merinos Apr 18 '17 at 14:58

Did you check this?

Although that is the pro version of drivers, the non open source.

If you like me bought radeon instead of nvidia since you want to use open source perhaps upgrading kernel to 4.7?

My RX460 was only in software rendering mode, now it works.

First I Updated to Kernel 4.9, downloaded these files to a temporary folder

linux-headers-4.9.0-040900_4.9.0-040900.201612111631_all.deb
linux-headers-4.9.0-040900-generic_4.9.0-040900.201612111631_amd64.deb
linux-image-4.9.0-040900-generic_4.9.0-040900.201612111631_amd64.deb

and did:

sudo dpkg -i *.deb

That was a needed step but not enough.

From this thread I got the remaining needed instructions.

Basically (if I remember correctly) I did this:

sudo apt-add-repository ppa:paulo-miguel-dias/mesa
sudo apt update
sudo apt install xserver-xorg-video-amdgpu mesa-utils
sudo apt upgrade
  • I was working on it (well my son was). Wanted to share the progress so far. And I get a downvote? – user2071943 Jan 10 '17 at 0:13
  • When users vote on answers, they do so for the answer in the state they see it and rightly so. If you want to save a draft and come back to it later, there is a save draft button below the the question box., answers should be complete when posting. Having said that, I can see you made a clear effort to improve this since I saw it in review and I will vote you up for that but unfortunately, the downvoter may never return to change there vote. Be careful when posting and use drafts and you should be able to avoid this situation happening again. – Mark Kirby Jan 10 '17 at 11:38
  • I just upvoted it because it seems like a fair answer, I will test this secondly if the first one doesn't work. I bought an AMD because I think it was cheaper than its NVIDIA Counterpart and because I like red better than green :p – David Merinos Jan 10 '17 at 17:19
  • Did everything you said and no luck, however I got into the recovery mode and pressed the network option, then after a bunch of messages appeared (No such file or directory) I spammed Ctrl+C until I got some GUI. This is how I performed all you said using the terminal. I still have some Error messages now and then referring XOrg thing but I can deal with this for now. Will continue investigating how to properly install amd-gpu pro thing. I still cannot see propiertary drivers in Drivers section. Thanks for your time. – David Merinos Jan 20 '17 at 4:38

AMD provides the updated drivers for this GPU. For installing the driver you need to go to the following link and download the tar.xz file. AMD gpu pro drivers for linux

To download from the command line, go to the folder where you want to download and


For downloading , one can download the file on a different PC and then transfer to the system using a USB drive. (I tried wget but the file is not downloaded as a package.)


After download (or copy from USB drive), unzip the file to a folder.

tar -Jxvf amdgpu-pro-16.50-362463.tar.xz

Next, use terminal (command line interface) to go inside the folder and run the following script. amdgpu-pro-install

by

./amdgpu-pro-install -y

(probably you will need sudo access)

After installation, reboot and you should get the GUI. (Tested with RX470, RX480 cards).

  • I will be testing this today and comeback in a few hours, at work right now. Thanks. However, did you copied the tar file from an usb or something like that into your home folder using console only? – David Merinos Jan 10 '17 at 17:12
  • I copied the downloaded file using a USB drive to the target computer. Downloading from the terminal does not work. – ankit7540 Jan 15 '17 at 6:49
  • Did this, it didn't work with my case. – David Merinos Jan 20 '17 at 4:36

I'm running 16.04 based elementaryOS and KDE Neon distros and to get my RX460 working well, I installed the preview linux-generic-hwe-1604-edge package (4.8 kernel) and the Xorg Edgers PPA. Apparently either around the 19th of this month or maybe some time next month the new X stack with 4.8 kernel should show up in the 16.04.2 release anyway so hang in there.

Support for the Polaris 11 based RX 460 in the form of built-in open source "amdgpu" driver update was apparently added around the 4.7 kernel release IINM.

i also tried the amdgpu-pro-16.50-362463 (actually more than 5 times on several distros, and the previous ones as well). each time i reboot after, i get a black screen or, the login screen keeps repeating like i have entered wrong password.

password not wrong, black screen is misleading: the pc is working, you need to log in using Control+alt+F4 or F2 etc. then you need to remove the waste of time driver with

amdgpu-pro-uninstall

ive used over 5 distros/variants of versions too. AMD fail on each one. Sorry, that might not be a good answer, but it is accurate.

edit: i also have tried ubuntu with kernel 4.9 and fail that too.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.