3

I've just started using Thunderbird instead of web mail because I'd like the ability to view and send emails offline.

I currently have it connected to Gmail using IMAP, but in order to sync I have to manually select sync from File > Offline > Download/Sync Now , and even then it appears to still download the entire inbox instead of just the recent ones.

How can I automatically keep the last 90 days worth of mail on my computer without deleting anything from the server?

These are my current Synchronization & Storage settings but they don't appear to do much:

Synchronization & Storage settings in Mozilla Thunderbird

And here are the Server Settings:

Server Settings in Thunderbird

  • 1
    Can you use POP? It's easy to set that up to download copies of the emails while leaving the originals on the server. – Organic Marble Jan 8 '17 at 20:22
2

It is definitely possible to synchronise offline mail in Thunderbird using IMAP. I am doing just this, for both a Google account and another IMAP account. Using IMAP (in my opinion) is preferable to POP3, because I can make changes locally and they get reflected in the webmail server and then also on other machines I have Thunderbird running on.

I don't remember the exact steps, but setting up the Google account was different. There is a different wizard for it that makes it easier, and this also provided some settings for me. It sounds like you've been able to get Gmail working in Thunderbird over IMAP - so you must have found this wizard.


I have a number of custom folders, so I had to do this for each of the ones I was interested in. Right-click on the folder, and go to Properties. I had to check the "When getting new messages for this account, always check this folder" option to ensure I got notifications properly - sometimes I would miss seeing new e-mails in custom folders.

Thunderbird Folder Properties 1

Then under Synchronization:

Thunderbird Folder Properties 2

It can take some time to download all the messages, but I am able to access them offline.

The only difference with your setup and mine is I have set to store all e-mail. I don't know how the above "Select this folder for offline use" will correspond with the 90 days setting you have globally for the account.

  • btw I don't have to choose anything from the File > Offline menu for the above to work - it does it automatically. – seanlano Jan 8 '17 at 23:13
  • 1
    Cheers for this, it seems like I only had to Download Now initially – Roshan Bhumbra Jan 9 '17 at 18:58
  • Out of interest, did the 90 days thing work properly? – seanlano Jan 10 '17 at 1:08
  • It doesn't look like it as I've got years worth of mail in my all folder. I'm not too fussed though. – Roshan Bhumbra Jan 10 '17 at 7:02
  • Ah OK. It might not have downloaded it all though. I think that Thunderbird will get the headers for all the mail, but not necessarily the whole message content. Try and see if messages older than 90 days only have their headers. (I guess you could do this by going offline and seeing if new messages can load and old ones can't). – seanlano Jan 12 '17 at 0:47
3

I'm using T Bird 45.5.1.

I don't allow software to delete any emails, except by rules/filters.

So, that said, I would check your server settings first.

My SERVER SETTINGS for my gmail imap account ARE CHECKED for the following:

Check for new messages at startup Check for new messages every 10 minutes Automatically download new messages Leave messages on server...until I delete them

On the advanced tab, under Message Storage, I select to use the "Local" Inbox. (this allows you to use global rules for filtering)

NOTHING else is checked.

On Sync and Storage, the only difference I have from yours is that I select to sync all messages locally regardless of age. If I want to delete certain aged ones, I create a filter/rule.

Server Settings

enter image description here

Sync Settings

enter image description here

Filter Settings

enter image description here

  • I can't see the Automatically download new messages or Automatically download new messages (See edit) I'm also on v45.5.1 – Roshan Bhumbra Jan 8 '17 at 21:27
  • Oh, it looks like you're using POP3, I'll give that a go as suggested by @Organic Marble – Roshan Bhumbra Jan 8 '17 at 21:29
  • It looks like you're connecting to imap.googlemail.com so I'm now more confused – Roshan Bhumbra Jan 8 '17 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.