I installed ubuntu 16.04 LTS in Oct. last year on my newly bought HP Envy i7-6700 CPU (x64-based 3.4GHz 4-core 8 -processors, 16 GB ram, 2TB hard drive), it was running OK until just before the X-mas holidays when it became very slow, some times grey window frame. It seems stuck somewhere.

  • It seems related to Internet browser, or, LibreOffice, Java – Jinstone Jan 8 '17 at 16:31
  • Check into the log files specifically the update logs and check what was updated around the time things started to slow then update your question with the relevant information, might help narrow things down. you can navigate into /var/log check the files inside any directory that relates to upgrades. you can open the files in gedit or another document reader with right click. You may also need to look into the archived files .gz – Chris Jan 8 '17 at 16:41
  • It just showed an error message when I rebooted it: "Sorry Ubuntu 16.04 experienced an internal error" I chose to send the error report to help identify the issue. I have looked at the syslog, it gives tons of GBus error on org.freesktop.PolicyKit1.Error.Failed, permission denied on .cache/dconf/user, gnome-software 1739... – Jinstone Jan 8 '17 at 16:56
  • See this thread on same issue. askubuntu.com/questions/761745/… – oldfred Jan 8 '17 at 18:50
  • It may not be your case, but it was mine. I also use linux, tried all these tips, but the real cause was overheating in the processor. I disassemble the entire notebook, unclogged the air ducts, and became fast as when I bought it. Obviously the problem is not about with the operating system. – dellasavia Jul 19 '18 at 21:20

As the other answer, my solution was to disable SpeedStep on the BIOS. I found out that the my cpu was running slower. My CPU should run at 1800MHz, but is was running at 1000MHz. You can see the current CPU speed using several shell commands, e.g:



cat /proc/cpu

It seems there was a problem with my charger and that made Ubuntu put the CPU into low consumption mode.

| improve this answer | |
  • 2
    Awesome, just unplugged my charger and it started working like before. I'll try to disable SpeedStep, but would be nice to know how to fix it in Ubuntu (Razer Blade Stealth here( – Guerlando OCs Dec 14 '17 at 1:04
  • I have a Thinkpad13 and charging via USB-C make Ubuntu slow down to a crawl. – Konstantin Schubert May 11 '18 at 17:45
  • I disabled SpeedStep in my machine and it got extremely slow. – Jaumzera Aug 14 '18 at 21:35
  • Is there a way to increase the min hertz on a machine? – Alexander Mills Mar 30 at 23:59

I have Ubuntu 16.04 running on a Dell Precision M4800. Today, my system suddenly became extremely slow. Googling the issue brought me here.

I fixed the issue by booting into the BIOS and disabling some of the power management features designed to reduce CPU power consumption when there is little work to do. After rebooting into Ubuntu, my system is running as fast as normal again.

I had this issue with a previous laptop as well-- somehow, it seems like it's possible for Ubuntu to get the Intel CPU "stuck" in a low-power, low-performance configuration permanently.

| improve this answer | |
  • 4
    It'd be great if you tell us which settings. – Kazim Zaidi Mar 1 '18 at 9:28
  • 1
    @KazimZaidi Sorry, I don't remember which settings they were. There were at least two, and I didn't test to see if all of them were necessary. I don't have any special knowledge here so it would be difficult for me to diagnose the problem in detail. – Max Wallace Mar 5 '18 at 5:46
  • seems risky - screenshots and more specific instructions would help! – Alexander Mills Mar 30 at 23:50

when its slow issue this in a terminal window ( ctrl-alt-t ) to display top resource using processes


here is the output ... notice load average at right of first row

top - 11:48:11 up 3 days, 8 min,  1 user,  load average: 0.23, 0.39, 0.54
Tasks: 276 total,   1 running, 272 sleeping,   0 stopped,   3 zombie
%Cpu(s):  1.8 us,  0.7 sy,  0.0 ni, 95.2 id,  2.3 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem : 16326792 total,  6946732 free,  1726764 used,  7653296 buff/cache
KiB Swap: 16669692 total, 16669692 free,        0 used. 13860968 avail Mem 

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                                                         
17093 stens     20   0 1629772 446180 121904 S   5.6  2.7 137:51.51 firefox                                                         
14358 stens     20   0 1390800 420448 113728 S   4.2  2.6   0:35.42 Web Content                                                     
 1219 etcd      20   0  639392  28764  12468 S   2.8  0.2   9:24.84 etcd                                                            
 1531 root      20   0  470212  72960  56564 S   1.4  0.4  25:49.02 Xorg                                                            
 2718 stens     20   0 1266236 112712  61796 S   1.4  0.7  52:15.46 compiz                                                          
 2757 stens     20   0  506036  25220  19440 S   1.4  0.2  32:02.48 indicator-multi                                                 
 3228 stens     20   0  712920  69960  35624 S   1.4  0.4   2:51.65 gnome-terminal-                                                 
 3488 root      20   0  251432  53740  24132 S   1.4  0.3   5:33.92 mongod                                                          
13335 root      20   0       0      0      0 S   1.4  0.0   0:01.17 kworker/u16:3                                                   

typically it will appear slow once load average gets over 5 or so YMMV ... listed under COMMAND is the ordered column of top resource consumers ... when its slow kill off whichever process is slowing it down to confirm you found the bad behaving process ... while running top it will autorefresh every few seconds yet if in a hurry hit the spacebar to force a refresh ... hitting key m will focus attention on showing Memory hungry processes ... to kill off the top most resource consuming process just hit key k from which you can enter options or just hit enter

Above has nothing to do with being slow due to insufficient internet bandwidth. If by slow you mean the browser is slow then a simple check is http://beta.speedtest.net/

Alternatives to top are


Another route to investigate slowness is see if system errors are getting kicked down into system log ... issue


look for entries (to scroll up in terminal hold down shift then hit key page up ... or roll mouse middle roller button ) important entries are shown in red or appear error related then research on them ... if you are running some rogue driver not tuned to your hardware or fails to play well with others then its conflicting behaviour can manifest in slowness ... to empty out prior entries issue

sudo    dmesg -c

to setup a real time monitor of dmesg issue

watch "dmesg | tail -20"

Here are more logs to examine

cat /var/log/syslog

cat  /var/log/kern.log 

Let us know how you get on - this is certainly solvable ... a major advantage of linux is its efficient use of hardware as well as its ability to give at hand controls to adjust everything

| improve this answer | |
  • htop auto refreshes, if not installed just install it sudo apt install htop has the same information, load averages at the tip etc. – Chris Jan 8 '17 at 17:01
  • Added advantage i forgot to mention, you can kill a process from within htop by highlighting and pressing the appropriate F key – Chris Jan 8 '17 at 17:03
  • @Scott Stensland load average is related to the number of cores I believe. If his processor has 4 cores, then load average shouldn't pass over 4. – fugitive Jan 8 '17 at 17:05
  • @MilosM yes its related to cores yet I mentioned it as a starting point ... if its slow and load average is low ( less than say 5) then slowness is not related to running out of CPU/RAM ... – Scott Stensland Jan 8 '17 at 17:07
  • @Jinstone I suggest one that I use often on my work. atop. It can perform various checks. Not sure is it installed in Ubuntu, if not apt-get install atop , and run it to check every sec like: atop -n 1. You can filter various stuff from there. – fugitive Jan 8 '17 at 17:11

Install package called i7z and run it. It will show you whether your cpu is running at full speed and cpu throttling (=lower speed) is not active.

| improve this answer | |
  • what is install command and perhaps provide a link? ty – Alexander Mills Mar 30 at 23:59

I did some change in swapiness and cpufreq and it worked well on my Ubuntu.

This is the script I wrote:

#Check if cpufrequtil command exisits in linux system
if ! command -v cpufreq-set > /dev/null
    echo "Let me install cpufrequtils for you."
    sudo apt install cpufrequtils
    echo "Great you already have cpufrequtils installed."
echo "Let me set your CPU to give better performance."
#Set cpu to performance
sudo cpufreq-set -r -g performance
#Set swappiness to 0 to use maximum RAM and use
sudo echo 'vm.swappiness=0' >> /etc/sysctl.conf
echo "***Please restart to let changes take effect***"

You can download the script from GitHub and run it by triggering command sudo ./fast.sh.

| improve this answer | |
  • Can you add some instruction about how to use the script? (e.g. download the script and run ./fast.sh etc.) – Archisman Panigrahi Aug 19 at 15:19
  • 1
    Also, swappiness = 0 might make the computer unresponsive if too much ram is in use, a swappiness of 5 or so would be preferable. – Archisman Panigrahi Aug 19 at 15:20
  • @ArchismanPanigrahi download the script and run it as you mentioned bu triggering command ./fast.sh . Regarding swappiness = 0 I;ve applied same on my Ubuntu 20 with i5 and 16GB Ram ... and it never goes above 60% usage ... but thats true you can change the value based on your config. – Saurabh Aug 20 at 13:15

I came here because suddenly my ubuntu is really slow, mouse pointer freezes and jumps, videos jumps and sound clipping. None of these solutions helped me, but I write this here in case someone finds it useful, and if someone who can do something read this. I solved this problem booting with a different kernel version, whenever I boot the last update (for me it's 4.4.0-169), it becomes slow, but when I boot with any previous one it runs nice. Something happened with the new versions.

| improve this answer | |
  • Welcome to AskUbuntu, you should answer the question with the clear description, would you mind to edit this in details, what you did, the way to do that. For example, command you used. That makes people understand better. – Sadaharu Wakisaka Dec 4 '19 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.