Since past few days, I have observed a strange behaviour on my Ubuntu machine, that whenever I open Chrome; a prompt window of unlock login keyring to enter my password opens up. However, I have not set up any password in keyring or chrome. So why this happening and how to stop this behaviour? Ubuntu version is 16.04 and Chrome is 55.0.2883.87.


A workaround. Open the terminal and go to:

cd /opt/google/chrome


ls -l 

to see if the google-chrome uses root:root. If so, then try:

sudo chown -R username:host /opt/google/chrome/google-chrome

Where the username is your username and host being your main host. Close the terminal and open Chrome again. If this is not working you might also need to change ownership in the /usr/bin and /usr/share/applications folders

sudo chown -R username:host /usr/bin/google-chrome-stable

sudo chown -R username:host /usr/share/applications/google-chrome.desktop

Remember though that this is a security risk.


This will occur when you boot without a password.If you reconfigure to use a password at bootup,the keyword thing goes away.There are workarounds to boot without any passwords,but not recomended for security reasons.I havent tried any of these workarounds,but I'm sure you can find them on a security tag.Good luck.It was pointed out to me that getting rid of all password protection is like turning off UAC in windows-BAD idea,very insecure.

  • I think you are right, I have disabled password on logon to Ubuntu and most probably it is having since then only. This basically answers the 'Why' part of the question. Thanks! – A.K. Pandey Jan 8 '17 at 14:54

I am using Vivaldi (on Xubuntu 18.04) rather than Google Chrome but the issue is the same. When the browser is launched I am asked for the password to unlock the keyring a number of times (four!). Disabling auto-login appeared to cure the issue for a day but after that it was back as before. Simply cancelling each dialogue box is sufficient to get the browser working fine. I'll try the file ownership changes proposed by user633551

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.