0

I bought a new dell laptop a couple of months ago that's running Windows 10. I did not install a password. I had heard about the secure boot and disabled it through the UEFI (F12 on startup).

I wanted an app (Microsoft now has an app store) but they make you get a Microsoft account. A few days later I shut down the machine and upon restart, it asked me for a password.

I knew that I could get into the machine and see the files (my passwords are in a text file on my windows desktop) if I installed Ubuntu.

I tried to see the files from the "Try Ubuntu" but they weren't accessible, so I made a small partition and installed Ubuntu. That's when I first heard about fast boot. Ubuntu installed OK. I have the grub menu that shows both Ubuntu and Win 10.

When I try to boot to Windows 10 I get a pixelated screen and it will not boot. I also can't access UEFI by hitting F12. My guess is I needed to disable the fast boot in Windows before I installed Ubuntu, but it's too late now.

Is there a way I can turn off grub or disable that feature from within Ubuntu?

I can't access the UEFI to get to the boot menu and it's stuck on booting from the HDD so I can't boot from a CD or USB.

I only need to get into Windows one time to turn off the hibernation/fast boot but can't find a way.

Any help you can give will be greatly appreciated!

  • You can always access UEFI settings pressing ESC immediately after powering up. Also now from Grub menu. However, it won't fix your Windows. Your assumption about a different result for the installed Ubuntu vs. Live session is wrong and stems from ignorance about how newer Windows deals with its own partitions (fast startup = hibernation). You may or may not need Windows installation or recovery media to fix it. Either way this is NOT a Ubuntu question. – user589808 Jan 8 '17 at 15:02
  • You don't need to install Ubuntu to access your Windows files and installing it will not change how easy or difficult it is to access them. Could you please boot a "live" DVD/USB with Ubuntu, choose "Try Ubuntu", and try to access your Windows files. What exactly are you trying and what happens? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. (see How do I ask a good question?) – David Foerster Jan 8 '17 at 15:03
  • Cold boot to get into UEFI or BIOS, remove battery or fwsetup in grub menu. askubuntu.com/questions/652966/… – oldfred Jan 8 '17 at 15:42
  • @CelticWarrior I tried holding the escape key down and hit the power on button. The system went straight to the grub boot menu. I've also tried F2, F8 and F12. Each time the system goes directly to the grub boot menu. Consequently I can't change the boot sequence because it's stuck on the HDD. I want to be able to use the dual boot, but since installing Ubuntu without first disabling the fast boot it won't let me. When I select Win 10 from the boot menu it goes to a pixelated screen and won't boot. I had no problem with access my windows files prior to installing Ubuntu. – golfnut72 Jan 8 '17 at 19:11
  • @DavidFoerster I tried inserting the same Live disk that I used to install Ubuntu last night and it won't boot the disk - it goes straight to the grub menu. I also can't see my windows files now (I assume it's because windows is in hibernate). This is what I get when I try to access the files: Error mounting /dev/sda2 at /media/ron/1ABC6F84BC6F58F1: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda2" "/media/ron/1ABC6F84BC6F58F1"' exited with non-zero exit status 14: Hibernated non-system partition, refused to mount. More... – golfnut72 Jan 8 '17 at 19:24
0

Sometimes EFI boot settings get damaged, making it difficult or impossible to boot into the firmware setup utility (what you're calling "the UEFI"). This can create a chicken-and-egg sort of situation, since the solution to such a problem is to reset all the firmware settings to the default, but you have to access the firmware setup utility to do this. I can think of several possible workarounds:

  • You could try putting my rEFInd boot manager on a USB flash drive or CD-R and boot to it. On most EFIs, rEFInd shows an option on the second row of icons to reboot into the firmware setup utility. Select this, reset the options to their defaults, use rEFInd again to reboot to Ubuntu, and re-install GRUB (sudo grub-install) to get things working again. If you can't get rEFInd to boot from the USB drive, you could install it to your hard disk, but that runs the risk of further corrupting the firmware settings.
  • GRUB includes an ability similar to rEFInd's, but it's often not active. I don't know offhand what an entry to do this looks like, but if it's not present in your GRUB menu, you could try to track this down and create such an entry. You'd then be able to use your existing GRUB to get into the firmware setup utility, much as you'd use rEFInd, then reset its options to their defaults.
  • You could turn off the computer, unplug all your hard disks, and start the computer. With no disks, the computer should launch its firmware setup utility. You can then reset the options to their defaults, plug the disks back in, and restart. The machine might not boot, though, or it might boot to Windows. If the latter, you could use EasyUEFI to create a new entry for GRUB/Ubuntu (its boot loader is EFI\ubuntu\shimx64.efi or EFI\ubuntu\grubx64.efi; the former supports Secure Boot, the latter doesn't). In either case, you could use rEFInd to boot into Ubuntu on a one-time basis or use Boot Repair to fix GRUB.

There may be other ways to do this, too. Using efibootmgr in Ubuntu to delete redundant entries might fix the problem, for instance. (Type sudo efibootmgr or sudo efibootmgr -v to see existing entries, then delete unwanted entries with sudo efibootmgr -b #### -B, where #### is the hexadecimal number of the boot entry you want to delete.)

Not the answer you're looking for? Browse other questions tagged or ask your own question.