0

I was trying to install steam (from both the steam:i386 package, and the steam_latest.deb package provided on the steam).

In both cases, steam fails to launch/install due to "required dependencies":

steam:i386 : Depends: libgl1-mesa-glx:i386

I made sure multiarch was enabled with

sudo dpkg --add-architecture i386 && sudo apt-get update

Trying to install the dependency:

sudo apt-get install libgl1-mesa-glx:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libegl1-mesa-lts-xenial : Depends: libgbm1-lts-xenial (>= 7.11~1) but it is not going to be installed
                           Depends: libgl1-mesa-dri-lts-xenial (= 11.2.0-1ubuntu2~trusty1) but it is not going to be installed
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.6)
                        Depends: libudev1:i386 but it is not going to be installed or
                                 libudev0:i386 but it is not installable
                        Recommends: libgl1-mesa-dri:i386 (>= 7.2)
 libsdl2-2.0-0 : Depends: libwayland-egl1-mesa (>= 10.0.2) or
                          libwayland-egl1
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

so it would seem i'm missing libegl1-mesa-lts-xenial, libgl1-mesa-glx:i386, and libsdl2-2.0-0

However, checking those, I realize that libegl1-mesa-lts-xenial is already installed on the system (and I've reinstalled it to make sure) and so is libsdl2-2.0-0. (As an aside, I'm surprised at how useless the apt-get output is at conveying the actual source of the error.)

Thus the problem seems to lie with libgl1-mesa-glx:i386

Installing it fails, as it depends on:

libglapi-mesa:i386 libudev1:i386

Ok, further down the rabbit hole. installing the first dependency:

sudo apt-get install libglapi-mesa:i386
[...]
The following packages have unmet dependencies:
 libegl1-mesa-lts-xenial : Depends: libgbm1-lts-xenial (>= 7.11~1) but it is not going to be installed
                           Depends: libgl1-mesa-dri-lts-xenial (= 11.2.0-1ubuntu2~trusty1) but it is not going to be installed
 libsdl2-2.0-0 : Depends: libwayland-egl1-mesa (>= 10.0.2) or
                          libwayland-egl1
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Hmm. the so called 'unmet dependencies' (libegl1-mesa-lts-xenial, libgbm1-lts-xenial, libgl1-mesa-dri-lts-xenial, libsdl2-2.0-0, libwayland-egl1-mesa) are all already installed... Reinstalling them does not fix the issue.

Ok. The other one?

So let's try to install it:

 sudo apt-get install libudev1:i386
The following packages have unmet dependencies:
 libudev1:i386 : Depends: libcgmanager0:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Finally:

 sudo apt-get install libcgmanager0:i386
The following packages have unmet dependencies:
 libegl1-mesa-lts-xenial : Depends: libgbm1-lts-xenial (>= 7.11~1) but it is not going to be installed
                           Depends: libgl1-mesa-dri-lts-xenial (= 11.2.0-1ubuntu2~trusty1) but it is not going to be installed
 libsdl2-2.0-0 : Depends: libwayland-egl1-mesa (>= 10.0.2) or
                          libwayland-egl1
 libudev1 : Depends: libcgmanager0 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Same as before. All the dependencies are already installed.

This was originally about installing steam, but I can do without. However, I can't figure this out and it's driving me crazy.

Any clues?

  • 1
    Enable the Partners repository and then simply: sudo apt-get update && sudo apt-get install steam. Avoid using the .deb provided by Steam and instead install it from the official repository (as you should do for most software). – user589808 Jan 8 '17 at 12:14
  • @DavidFoerster interesting, how does one use apt-get to find out which drivers are affected? – Dugas Jan 9 '17 at 13:30
0

You have a mix of graphics drivers from Ubuntu 14.04.1 and the “LTS Hardware Enablement Stack” of Ubuntu 14.04.5 (the *-lts-xenial packages) and the two cannot coexist on the same system. Please decide for one graphics driver set (I recommend the LTS variants if you care about gaming).

You can list all those packages with apt-cache search '.*-lts-xenial$' and you can perform a full multi-arch LTS upgrade with:

sudo apt-get install -f --install-recommends linux-generic-lts-xenial xserver-xorg-core-lts-xenial xserver-xorg-lts-xenial xserver-xorg-video-all-lts-xenial xserver-xorg-input-all-lts-xenial libwayland-egl1-mesa-lts-xenial libgl1-mesa-glx-lts-xenial libgl1-mesa-glx-lts-xenial:i386 libglapi-mesa-lts-xenial:i386

(source and further info: Kernel/LTSEnablementStack)

If that doesn't work out cleanly (which may happen, especially with many PPAs or with existing package management issues), please open a new question asking how to perform the LTS HWE upgrade and include the full, verbatim output of the above command.

  • Thank you, that does seem to be the cause of this, so I've marked your answer as accepted. The command for upgrading to LTS failed however (` libgl1-mesa-glx-lts-xenial:i386 : Depends: libudev1:i386 but it is not going to be installed`), and I think that's as far as I'm willing to go with this issue. – Dugas Jan 22 '17 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.