2

When trying to boot normally from grub I get a black screen when it should be showing me the password field for my boot partition. Entering the password anyway does not boot Ubuntu.

When I delete quiet splash from the boot options then the last line I can see is about EHCI, but no errors are visible. At that point the boot process hangs and the only thing that I can do is reboot with CTRL+ALT+DEL.

Booting with the recovery mode works as expected. The dialog asking for the root partition password appears and everything works as expected after I select the resume option twice.

I tried running boot repair and get this paste from it: http://paste2.org/CVcxaMpp

The BIOS is set to boot from the correct disk /dev/sda

I have recently upgraded my graphic card from an old nvidia to a newer nvidia card, but I am not sure that the problems started at that point.

I have tried to swap my keyboard and mouse before booting to rule out that they are the problem. This didn't change anything.

I have tried to disconnect all disks besides the main ubuntu disk, but that didn't help either.

Changing the boot options from quiet splash to nomodeset and adding a delay to /etc/init.d/sddm

# Wait for plymouth if running
[ -x /bin/plymouth ] && /bin/plymouth quit
sleep 2
call do_start_cmd

just let me boot almost normal. Doing only one of these does not work. Unfortunately I don't get a nice looking boot process when I remove quiet splash.

  • 1
    Your new Nvidia card most likely needs nvidia proprietary drivers. Edit the boot options and use nomodeset instead. This will give you generic Vesa video so you can install the recommended drivers for your new card. It has nothing to do with bootloaders. – user589808 Jan 8 '17 at 11:59
  • The newest nvidia drivers are already installed. Although I did not install them after the graphic card upgrade. sudo ubuntu-drivers autoinstall does not install any additional drivers. – FlyingFoX Jan 8 '17 at 12:21
  • My question seems to be a duplicate of askubuntu.com/questions/527356/… – FlyingFoX Jan 8 '17 at 12:22
  • sudo ubuntu-drivers autoinstall does help – Maksim Kostromin Dec 29 '17 at 22:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.